PPPOE issues with UC500

Answered Question
Jul 19th, 2008

Hi

I have a UC500 and an ISP who asigns IP via PPPOE.

I am attaching the config (mostly default)

the PPPOE sessions seems to work but no IP is assigned.

anyone got any ideas



Attachment: 
Correct Answer by zeusinact about 8 years 7 months ago

Hi,


Kindly ask you to check this configuration steps, you should define vpnd also please use "ip address negotiated" under your dialer interface.


Best Regards,

Cumhur

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!


interface fastethernet0/0

description lan interface

ip nat inside


interface fastethernet0/1

description adsl interface - Physical

pppoe enable

pppoe-client dial-pool-number 1



interface Dialer1

description ADSL Interface - logical

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname

ppp chap password

ppp pap sent-username password


ppp ipcp route default



ip nat inside source list 15 interface Dialer1 overload

!

access-list 15 permit 192.168.10.0 0.0.0.255

!!!!

!!!! Determine which protocol to pass through

dialer-list 1 protocol ip permit

!!!!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Kenneth Mohammed Sat, 07/19/2008 - 13:18

Hi,


Have you verified that your external dsl/cable modem is in "bridge only" mode? If not, you may want to contact your ISP and have them guide you on how the external modem should be configured as a bridge only.


Hope that helped.

johnroche_2 Sat, 07/19/2008 - 13:38

Yes,

If i plug the cable into a laptop and configure a PPPOE dialer it works perfectly

johnroche_2 Sun, 07/20/2008 - 02:50

Here is the PPPOE debug....

Jul 20 09:58:17.803: PPPoE : Shutting down client session

Jul 20 09:58:17.803: [0]PPPoE 49: O PADT R:0000.c5b1.2b10 L:001b.8fae.2340 Fa0/0

Jul 20 09:58:17.803: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0

Jul 20 09:58:17.807: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

Jul 20 09:58:38.067: Sending PADI: Interface = FastEthernet0/0

Jul 20 09:58:38.211: PPPoE 0: I PADO R:0000.c5b1.2b10 L:001b.8fae.2340 Fa0/0

Jul 20 09:58:40.115: PPPOE: we've got our pado and the pado timer went off

Jul 20 09:58:40.115: OUT PADR from PPPoE Session

Jul 20 09:58:40.251: PPPoE 50: I PADS R:0000.c5b1.2b10 L:001b.8fae.2340 Fa0/0

Jul 20 09:58:40.251: IN PADS from PPPoE Session

Jul 20 09:58:40.251: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

Jul 20 09:58:40.251: PPPoE: Virtual Access interface obtained.

Jul 20 09:58:40.251: PPPoE : encap string prepared

Jul 20 09:58:40.251: [0]PPPoE 50: data path set to Virtual Acess

Jul 20 09:58:40.255: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

Jul 20 09:58:43.051: PPPoE : Shutting down client session

Jul 20 09:58:43.051: [0]PPPoE 50: O PADT R:0000.c5b1.2b10 L:001b.8fae.2340 Fa0/0

Jul 20 09:58:43.051: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0

Jul 20 09:58:43.055: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

uc500#

Jul 20 09:59:03.275: Sending PADI: Interface = FastEthernet0/0

Jul 20 09:59:03.455: PPPoE 0: I PADO R:0000.c5b1.2b10 L:001b.8fae.2340 Fa0/0

Jul 20 09:59:05.323: PPPOE: we've got our pado and the pado timer went off

Jul 20 09:59:05.323: OUT PADR from PPPoE Session

Jul 20 09:59:05.451: PPPoE 51: I PADS R:0000.c5b1.2b10 L:001b.8fae.2340 Fa0/0

Jul 20 09:59:05.451: IN PADS from PPPoE Session

Jul 20 09:59:05.451: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

Jul 20 09:59:05.451: PPPoE: Virtual Access interface obtained.

Jul 20 09:59:05.451: PPPoE : encap string prepared

Jul 20 09:59:05.451: [0]PPPoE 51: data path set to Virtual Acess

Jul 20 09:59:05.455: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

Jul 20 09:59:07.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up...



Correct Answer
zeusinact Sun, 07/20/2008 - 05:42

Hi,


Kindly ask you to check this configuration steps, you should define vpnd also please use "ip address negotiated" under your dialer interface.


Best Regards,

Cumhur

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!


interface fastethernet0/0

description lan interface

ip nat inside


interface fastethernet0/1

description adsl interface - Physical

pppoe enable

pppoe-client dial-pool-number 1



interface Dialer1

description ADSL Interface - logical

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname

ppp chap password

ppp pap sent-username password


ppp ipcp route default



ip nat inside source list 15 interface Dialer1 overload

!

access-list 15 permit 192.168.10.0 0.0.0.255

!!!!

!!!! Determine which protocol to pass through

dialer-list 1 protocol ip permit

!!!!

johnroche_2 Sun, 07/20/2008 - 10:52

Hi


UC500 does not use VPDN groups.


But when I entered the following commands in the dialer 0


ppp ipcp route default

ppp ipcp address accept


the interface got the IP



Thanks for the help




Actions

This Discussion