CTI: CG1A ctiserver

Unanswered Question
Jul 20th, 2008

Hi All;

What is the usage for CG1A ctiserver?

I am facing an error on it, but I tried to search for any thing related to it and did not find, the error is:

Error-INVALID_CSTA_CONNECTION_IDENTIFIER

PRIVATE_DATA - PeripheralErrorCode=0x2799<10137>

MsgType:CONTROL_FAILURE_CONF <InvokeID:0xa93 FailureCode:CF_PeripheralErrorCode:10137>

By the way, is it related to network issue?

What if Private Network was disabled?

Any help?

Regards

Bilal

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.3 (3 ratings)
Loading.
Abdulbaseer Mohammed Sun, 07/20/2008 - 05:39

CG1A cti server: most likely this is communicating with your end devices handsets or desktops.

Do you happen to have any Avaya IP phones or some sort of jtapi apps?

CTI server usually communicates with CAD, CTIOS or some sort of CRM with cti enabled.

Good luck.

bilalghayad Sun, 07/20/2008 - 07:17

Yes I have CRM integrated with CTI, the agent is not able to login from the CRM using the CTI integration. Thsi integration use JTAPI.

But using the CAD, the agent is able to login. I do not know why from the CAD is working and why from the CRM via the JTAPI does not work?

Does CAD use something else so it is able to login, while JTAPI use the CG1A and it is not able to login because of the error?

From the other side, I have a public network and private network on each IPCCE server of my solution, just before week I got a problem in private network due to the network switches, and it look like the error on the CG1A appears since that time, but I am not able to know why the private network effects on that process?

Regards

Bilal

bilalghayad Sun, 07/20/2008 - 15:14

We were not having this error, and it is not existed in all our sites.

It is ITS product, and the module called CTCMAIN. Do not worry, it should work fine.

Any help regarding the error on the process and its relation if the private network icon is disabled due to network problem (but publick network icon is working fine)?

Regards

Bilal

bilalghayad Sun, 07/20/2008 - 15:14

We were not having this error, and it is not existed in all our sites.

It is ITS product, and the module called CTCMAIN. Do not worry, it should work fine.

Any help regarding the error on the process and its relation if the private network icon is disabled due to network problem (but publick network icon is working fine)?

Regards

Bilal

Abdulbaseer Mohammed Sun, 07/20/2008 - 22:56

CAD is more tightly integrated. Sounds like some things changed in network connectivity not allowing your CRM servers to talk with CTI box or PG's with related info.

What CRM you are using try to communicate to thier Integration department.

Does your CRM succesfully send or receive events to Cisco IPCC/ICM?

Please rate helpful posts.

Good luck.

bilalghayad Mon, 07/21/2008 - 03:59

Just need to understand the nature of the work for CG1A ctisvr.

As I understand that CG1A ctisvr process is used for CTI clients that was created using the CTIOS SDK, while ctios server process is used for clients that need to login using the CAD (standalone, not SDK).

My error in the CG1A ctisvr process which is related to the CTIOS client created by the SDK and embeded in our CRM (ITS product).

The error was not existed before, it is new and appeared just after the network changes.

Well, I beleive it is related to network but I would like to unerstand why the error appears before even the client is trying to login? The error appears once the process lunched and started, so it look like the process is trying to do a kind of communication and it failed because of network issue. I can access the PG server that contains the CG1A stisvr using PC AnyWhere and I can ping it, because the public network icon is enabled and working fine, while the private network icon is not working (even if I enabled) and this status appeared after network change.

In other words, why CG1A ctisvr is using the private network? For what?

Any help?

Regards

Bilal

>As I understand that CG1A ctisvr process is used for CTI clients that was created using the CTIOS SDK, while ctios server process is used for clients that need to login using the CAD (standalone, not SDK).

Not quite.

The CTI server normalizes the event stream for all the PG types - so that a soft phone client of the CTI server can work on all supported switches: CUCM, Avaya, Nortel etc.

Before there was the CTI OS (CTI Object Server), there was just the CTI server. Some of the early clients just talked to the CTI Server, and some current implementations (like the AMC connector for SAP) still talk to the CTI server.

The CTI OS is a higher level abstraction of call control that sits above the CTI Server. The CTIOS client (Soft Phone) talks to this.

CAD also talks to the CTIOS, but this is a recent change (7.0) - CAD used to talk to the CTI Server.

You should check the SRND.

Regards,

Geoff

Actions

This Discussion