License Problem on Evaluation Cisco NCM

Unanswered Question
Jul 21st, 2008

Hello,

I would like to test the "Network Compliance Manager" (NCM). The installation was successfull and the license-file (cwncm_13_core_default_eval_any_50_90days.lic) was copied to the specified directory during installation. After installation it is located in the installation directory as well. When trying to log in, I get the error message "No valid licenses found."

The Guide "Installing the CiscoWorks NCM License After Installing the CiscoWorks NCM Software " was not very helpful, as I cant log in to reinstall a new license :(

Any suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jason Davis Mon, 07/21/2008 - 04:43

Were the permissions on the file 640 root:root?

Did you try bouncing the NCM daemon manager?

/etc/init.d/truecontrol stop

/etc/init.d/truecontrol start

grafchristian Mon, 07/21/2008 - 05:02

Sorry, I forgot to tell you that it is a Windows 2003 Server.

Anyhow I restarted the "TrueControl Management Engine" Service, but nothing has changed.

I checked the "jboss_wrapper.log" and found that:

INFO | jvm 1 | 2008/07/21 14:27:16 | 14:27:16,825 INFO [LicenseManager] Getting Flex features

INFO | jvm 1 | 2008/07/21 14:27:16 | 14:27:16,825 INFO [FlexlmFeatures] Root: d:\CWNCM

INFO | jvm 1 | 2008/07/21 14:27:16 | 14:27:16,825 INFO [FlexlmFeatures] Got 1 license files

So it seems as if NCM finds the licensefile, but is unable to interpret it correctly.

I'm not sure if this is really a failure or if this is the (caught) Exception of the invalid license:

INFO | jvm 1 | 2008/07/21 14:27:39 | 14:27:39,543 INFO [STDOUT] {connect} [http-0.0.0.0-443-1] 75 RNLoginModule: Exception in login - javax.ejb.FinderException: No valid licenses found.

Another quote from that logfile is:

INFO | jvm 1 | 2008/07/21 14:55:13 | Monitor: LicenseMonitor

INFO | jvm 1 | 2008/07/21 14:55:13 | Description: Monitor for checking the number devices licensed and expiration date.

INFO | jvm 1 | 2008/07/21 14:55:13 | New Status: Warning

Maybe that information helps anyone ... still waiting for hints

Jason Davis Mon, 07/21/2008 - 05:09

Is your system running DHCP? I noted this in the log...

INFO | jvm 1 | 2008/07/21 14:27:39 | 14:27:39,543 INFO [STDOUT] {connect} [http-0.0.0.0-443-1]

Web connect to null IP? Might want to check that out. It seems abnormal.

Barring that being an issue...

NCM installs very quickly if you're using the embedded MySQL MAX database. 15 minute installs are the norm in my experience. Considering that you haven't gotten to a point of using the product yet, would you consider trying a re-install?

grafchristian Mon, 07/21/2008 - 05:27

I guess the 0.0.0.0 means just, that the SSL-Webservice is listening on all available interfaces. If you look into a 'netstat -an' command you can see a couple of services doing so.

The server is not running on DHCP.

I was already using the embedded Database, as a connect to a fresh MySQL 5 Database was not successfull (couldn't understand that, because connecting via Mysql-admin or from the commandline was successfull).

But you are right, the install process is pretty fast. I reinstalled and tried a lot of different things by now.

Jason Davis Mon, 07/21/2008 - 05:42

MySQL 5 db is not supported.

http://www.cisco.com/en/US/products/ps6923/products_quick_start09186a008092eedd.html#wp51946

If you're trying to go with an external database (or one that's self-provided)

http://www.cisco.com/en/US/products/ps6923/products_quick_start09186a008092eedd.html#wp51946

(Search Table 9)

Let's get back to basics here and try to reduce the variables. Make sure your MySQL 5 database is completely removed. Make sure there's no MySQL MAX 3.23 remnants either. The MySQL removal process on Windows is detailed here:

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_network_compliance_manager/1_3_SP1/user_guide/User_Guide.pdf

(Page 61)

Once you're certain all NCM and MySQL components are gone, then try the install again.

grafchristian Mon, 07/21/2008 - 22:20

I started a new installation of NCM with a MS SQL 2005 Server this morning and the installation worked without failure.

But once again when I try to log in, I still get the "No valid licenses found."

And the jboss_wrapper.log:

INFO | jvm 1 | 2008/07/22 08:16:58 | 08:16:58,299 INFO [STDOUT] {xyz} [http-0.0.0.0-443-6] 75 CWNCMPermit: Feature is invalid: CWNCM_CORE,1.3,1199137080000,1206913080000,50,0,1,0,,CWNCM_CORE -

INFO | jvm 1 | 2008/07/22 08:16:58 | 08:16:58,299 INFO [STDOUT] {connect} [http-0.0.0.0-443-6] 75 RNLoginModule: Exception in login - javax.ejb.FinderException: No valid licenses found.

Jason Davis Tue, 07/22/2008 - 03:28

grafchistian, email me your license file so I can see if it is corrupted. Also send the whole jboss_wrapper.log (zip it up).

[email protected]

Some other thoughts - what browser were you using?

Did you have this working OK before with just the embedded MySQL Max 3.23 and did it only happen when using the unsupported external MySQL 5.x (which you aren't using now). Has it just been happening with the MS SQL 2005 Server (which is supported fine)?

We'll keep digging. I'll plink around internally, but we may need to involve TAC. I'm on the post-sales professional services side - they are more the break-fix team. :)

grafchristian Fri, 09/05/2008 - 01:27

Yes, it is solved. After a couple of mails with the Cisco TAC, they sent me a mail with a working eval license.

I recommend to contact TAC (maybe with reference to this case) and ask them for a working license. It might be useful to tell them about the MAC-Address of the system you installed the trial version, as they might need it for generating a new license.

Christian

Actions

This Discussion