OSPF and RIP

Unanswered Question
Jul 21st, 2008
User Badges:

Hi,


I am trying to redistribute RIP into OSPF but im getting the following message;

"Only classful network is allowed"

And because of this i am not getting any RIP updates in my OSPF domain.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
dhananjoy chowdhury Mon, 07/21/2008 - 21:09
User Badges:
  • Silver, 250 points or more

if you do "redistribute rip" then it will only redistribute the classfull networks, like 10.0.0.0/8, 16.0.0.0/8 etc.


Now if you want to redistribute all routes both classfull and classless then give the command

"redistribute rip subnets".

drnteam Mon, 07/21/2008 - 22:14
User Badges:

Hi,


Currently I am using the command "redistribute rip metric 10". Do u wanna me to change to redistribute rip subnets.

karien.verster Mon, 07/21/2008 - 22:54
User Badges:

hey,


try doing it in 2 statements:

#redistribute rip subnets

#default-metric 10


maybe that will work. if it still comes up with an error, try moving to rip version 2.

Richard Burts Tue, 07/22/2008 - 03:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

The issue here is an OSPF issue. It would be the same if you use RIPv2 (or if you use EIGRP). dhananjoy correctly identified the issue is that if the subnets parameter is not used on the redistribute statement then only the classful networks (no subnets) are redistributed. You could use 2 statements or you can put both the subnets and metric parameters on the redistribute statement.


HTH


Rick

Actions

This Discussion