Best way to add 2nd gig link from 7604 to Metro Optical Ethernet?

Unanswered Question
Jul 22nd, 2008

I have a 7604 with SIP-400 and a SPA-1x2GE. This is connected to our provider's Metro Optical Ethernet (QMOE) at layer 2 - we apply L3 routing on our interfaces. This is at our data center (DC) and is connected at full gig speed. Our other sites are connected to the QMOE at 100MB ethernet connections.

On the L3 sub-interfaces we shape to just below 100mb and have QOS policies to manage Voice, video, etc. Here is the config of the gig port on the 7604 and a couple of sub-interfaces:

class-map match-any Call-Control

match ip dscp cs3

class-map match-any Video

match ip dscp af41

class-map match-any Voice

match ip dscp ef

!

policy-map QOS_classes_24calls_1video

class Voice

priority 2200

class Video

bandwidth 460

class Call-Control

bandwidth 100

class class-default

random-detect

policy-map WAN-100MB-speed

class class-default

shape average 99920000

service-policy QOS_classes_24calls_1video

interface GigabitEthernet2/1/1

description test QMOE link

no ip address

ip flow ingress

ip flow egress

load-interval 30

negotiation auto

no snmp trap link-status

cdp enable

!

interface GigabitEthernet2/1/1.50

description VLAN-50 to SBK,TSC (100MB)

bandwidth 100000

encapsulation dot1Q 50

ip address 168.75.189.1 255.255.255.248

ip flow ingress

ip flow egress

service-policy output WAN-100MB-speed

!

interface GigabitEthernet2/1/1.52

description VLAN-52 to CMB,TSC (100MB)

bandwidth 100000

encapsulation dot1Q 52

ip address 168.75.189.9 255.255.255.248

ip flow ingress

ip flow egress

service-policy output WAN-100MB-speed

With all the other remotes sites connected to QMOE at 100mb, we're oversubscribing the DC gig connection so I'm getting a second gig connection to be installed in another SIP/SPA in the 7604.

My question is, what is the best way to configure the 2nd gig? I want to have redundancy between the two so I'm thinking of creating an etherchannel of the two and moving the config to the port channel.

Is this a good idea in this scenario? How will that affect the QOS structure seeing as how the QOS policies will be on a virtual interface instead of a hardware interface - will the shaping change? How does the queue structure work in a port channel as compared to the hardware queues on the gig ports when working with LLQ bandwidth and priority limits?

Would it be better to have the 2nd gig connection a separate L3 connection and move half the sub-interfaces to it? This will not provide redundancy to all sites if a link goes down. Is the QOS cleaner with two separate gig connections?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
raeesshaikh Tue, 07/22/2008 - 07:10

The concept of using etherchannel is a better option than making the 2nd Gig as a seperate L3 interface. It will not have an impact on the QOS as the same policies can be applied to the ehterchannle as a whole. Also, this will give you the redudndancy that you require.

Regards,

Raees

Actions

This Discussion