Inter VLAN Routing and Cisco 1711

Answered Question
Jul 22nd, 2008
User Badges:

Hi,

I am trying to get inter VLAN routing working on a Cisco 1711 switch with the 4 port switch WIC but it is not working. I think its something simple but I can figure it out. I cant ping from the computers to each sub interface. i.e. I cant ping FastEthernet 0.10 IP address of 10.1.10.1 from a laptop plugged into FastEthernet 3. The laptop has an ip of 10.1.10.2 and is using 10.1.10.1 as its default gateway. Below is a copy of my config.


Router#show conf

Using 1045 out of 29688 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

!

!

!

!

ip cef

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

!

!

!

archive

log config

hidekeys

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

duplex auto

speed auto

!

interface FastEthernet0.10

encapsulation dot1Q 10

ip address 10.1.10.1 255.255.255.0

!

interface FastEthernet0.20

encapsulation dot1Q 20

ip address 10.1.20.1 255.255.255.0

!

interface FastEthernet1

switchport mode trunk

!

interface FastEthernet2

!

interface FastEthernet3

switchport access vlan 10

!

interface FastEthernet4

switchport access vlan 20

!

interface Vlan1

no ip address

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

!

end


Correct Answer by lgijssel about 8 years 9 months ago

O, I assumed it would.

In that case, thank you for rating my post;-)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Tue, 07/22/2008 - 10:37
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

That setup won't work.


Try this:


Remove the interfaces

no interface FastEthernet0.10

no interface FastEthernet0.20

!

!

Verify the vlans are created in Layer2

sh vlan-switch

!

If they don't exist

vlan database

vlan 10

vlan 20

exit

!

Create the Layer3 interfaces

interface vlan 10

ip address 10.1.10.1 255.255.255.0

no shutdown


interface vlan 20

ip address 10.1.20.1 255.255.255.0

no shutdown


Try pinging now.


HTH,


__


Edison.


Please rate helpful posts



lgijssel Tue, 07/22/2008 - 10:46
User Badges:
  • Red, 2250 points or more

You likely have to define the vlans in the vtp database:

#vlan database

vlan 10 name vl10

vlan 20 name vl20

exit

#

If this has not been done, the vlans will not become active.


regards,

Leo

Correct Answer
lgijssel Tue, 07/22/2008 - 12:00
User Badges:
  • Red, 2250 points or more

O, I assumed it would.

In that case, thank you for rating my post;-)

Actions

This Discussion