3750's, 7200 NPE-G1 and GEC advice.

Unanswered Question
Jul 22nd, 2008
User Badges:

Hi,


Just after some "best practice" advice on the following:


We have two 3750's(3750E-24TD-S) stacked, and a 7200 w/NPE -G1 - We are wanting to connect two of the GigE ports of the NPE to both 3750's(In case one switch fails) - We currently have it setup as port-channels, which is working fine, but wanted to confirm if this was the "correct" method to achieve redundancy, and also additional bandwidth between the 3750's + 7200.


During minimal testing, we lose ~2 packets if a cable is disconnected(If the session(ping) is running over that cable) - Is there anyway to reduce this?


Any suggestions are greatly appreciated.


Current conf..


7200:


!

interface Port-channel1

description GEC_to_3750s

no ip address

duplex full

hold-queue 150 in

!

interface GigabitEthernet0/1

description TO_3750_1_0_24

no ip address

duplex full

speed auto

media-type rj45

negotiation auto

channel-group 1

!

interface GigabitEthernet0/2

description TO_3750_2_0_24

no ip address

duplex full

speed auto

media-type rj45

negotiation auto

channel-group 1

!


3750s:


interface Port-channel1

description GEC_to_7200

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/24

description TO_7200_GE_0_1

switchport trunk encapsulation dot1q

duplex full

channel-group 1 mode on

spanning-tree portfast

!

interface GigabitEthernet2/0/24

description TO_7200_GE_0_2

switchport trunk encapsulation dot1q

duplex full

channel-group 1 mode on

spanning-tree portfast


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
lgijssel Wed, 07/23/2008 - 00:53
User Badges:
  • Red, 2250 points or more

Your solution is basically fine. I agree that channels are a good way to make such a connection.

However, you should leave everything on "auto" including the duplex-mode. This is the recommended setup for gigabit.

Also, you should remove the portfast commands from the ports on the 3750. It does not help you here and there is no need for it.

These little adjustments might result in a slightly faster convergence but missing two pings is not too bad.


regards,

Leo

Actions

This Discussion