871W in Universal Client Mode Bridging Issue

Unanswered Question
Jul 22nd, 2008
User Badges:

I have a 1242 Access Point as root and a 871W Router as a non-root bridge (Diagram attached). I have a laptop connected to Fa 0 of the 871W router.


* I am able to ping from the AP to the Router and vice versa

* I am also able to ping from the router to the laptop and vice versa

* But I am not able to ping from the laptop to the AP


All bridging commands seem to be fine. Even tried adding route commands, but none seem to work. All suggestion are welcome, Thanks.


Please find the configuration below:



Configuration on Root AP:



hostname ap

!

enable secret 5 XX

!

ip subnet-zero

!

!

no aaa new-model

!

dot11 ssid Cisco

authentication open

!

!

!

username Cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid Cisco

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

infrastructure-client

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.1.10 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.254

ip http server

no ip http secure-server

ip http help-path

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

End

Configuration on non-root 871W:


hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid Cisco

authentication open

!

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.20

!

ip dhcp pool ADSL_LAN_POOL

network 192.168.1.0 255.255.255.0

default-router 192.168.1.20

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

!

!

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

no ip address

shutdown

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

!

ssid Cisco

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role non-root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip tcp adjust-mss 1452

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.1.20 255.255.255.0

no ip route-cache cef

no ip route-cache

!

ip default-gateway 192.168.1.10

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
jennyjohn Mon, 09/01/2008 - 22:30
User Badges:

When station-role non-root is used, the router works in Universal Client Mode and it works in Layer 3. Hence Bridge-group commands on Dot11radio interface & Vlan 1 interface wouldn't work. Both interfaces have to be given an IP address and nat overloading needs to be done on the router to map the many router client IP address to the single dot11 IP address connecting it to the main network.


for more details:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40.2cc1907b

ekonishijunior Mon, 05/13/2013 - 19:07
User Badges:

I have the 871w router but I can´t change the station-role mode to non-root, I receive the following message:


can not disable station-role


Somebody know why i cannot change to station-role non-root?


thanks

Scott Fella Mon, 05/13/2013 - 19:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Do you have that option when you issue a station-role ?


Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode