The agent extension is out of service

Unanswered Question
Jul 23rd, 2008

I keep having multiple agents go from out of service then between 1-10 seconds later back in service?

IPCC 4.0(4)SR01_Build029

CCM 4.1(3)sr4d

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Chawki Salhi Thu, 07/24/2008 - 02:14


What is goind out of service? Is it the agent desktop application or the IPPA?

Chawki Salhi Thu, 07/24/2008 - 04:47


Could it be a network issue? Run a script on one of the agent computer on which you are meeting this issue to ping the IPCC server and send the result to a file. You will have the result when there is a disconnect.

I would advise you to have a look at one of the agent desktop computer logs.

Also, when the agent desktop application is out of service, try to double click in the toolbar on that status. It will show you a list of the IPCC services up or down. If all are down, this maybe a network issue.

Keep us informed!


richardpierce Thu, 04/16/2009 - 06:01

Chris I am having the exact same problem with a customer running IPCCX 5.0.1. Did you ever find a resolution to this fault?

sebastiaanv Thu, 04/16/2009 - 09:33


Are you experiencing this in a LAN or a WAN environment?


sebastiaanv Thu, 04/16/2009 - 22:47

Did you fully implement QoS between the agents and the IPCC environment?

Can you identify any heavy traffic on your network? I've seen this behaviour across WAN links when large databases would be copied.

Remember that CAD uses different ports than standard voice signalling. The attached PDF may provide you with more info (you might need to check if it differs from your CAD version).

You might also want to check what the status of the agent is in the Supervisor Desktop. I have experienced a problem where agents would still be set to a 'ready' state on the agent side when traffic problems occurred. The supervisor desktop would show them 'not ready' though (which represented the right state). This was over a WAN though.


This Discussion