Catalyst 3500 VLAN Config problem

Unanswered Question
Jul 23rd, 2008

I've got a Cisco Catalyst 3500 switch. I have an Access Point in port 13 which in on VLAN 20. That AP pulls its IP from our Gateway, and that part is working fine. The AP itself also has a VLAN setup on it because I want the users to pull from a differnt scope of IPs. I cannot get the users to get an IP address from the AP. Port 13 is setup for VLAN Access, how can I set it up for trunking the VLAN info from the AP. I was able to get this working with ZyXEL switches, just not with Cisco. Any help would be great

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Wed, 07/23/2008 - 12:21

you will probably have to post the configs of the switch and the AP . Is the AP a cisco also ?

jerrysafetynet Wed, 07/23/2008 - 12:38

Thanks. No, the AP is a Colubris Access Point

I enabled trunking on port 13, but that did not work. Gateway is plugged into port 24, Nomadix Gateway

sh run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SafetyNet

!

enable secret xxx

!

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

--More-- !

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

switchport access vlan 20

!

interface FastEthernet0/7

switchport access vlan 20

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

--More-- interface FastEthernet0/12

!

interface FastEthernet0/13

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport priority default 7

!

interface FastEthernet0/14

!

interface FastEthernet0/15

switchport access vlan 20

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

--More-- !

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface VLAN1

ip address 10.15.10.5 255.255.254.0

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 10.15.10.1

snmp-server engineID local 00000009020000B06490C940

snmp-server community private RW

snmp-server community public RO

snmp-server chassis-id 0x12

--More-- !

line con 0

transport input none

stopbits 1

line vty 0 4

login

line vty 5 15

login

!

end

SafetyNet#

Tarun Lohumi Wed, 07/23/2008 - 13:36

interface FastEthernet0/13

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport priority default 7

Thats not the correct configuration for a trunk.

interface FastEthernet0/13

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan

switchport priority default 7

By default the native vlan on a switch trunk port is 1, can you check what is the native vlan on the AP.

Try configuring a local DHCP on the switch to see if the problem is with the trunk port or somewhere else.

jerrysafetynet Wed, 07/23/2008 - 14:08

I've set the VLAN on the AP to 50. I'll try adding the switchport trunk native vlan 50 tomorrow. thanks for the help

jerrysafetynet Wed, 07/23/2008 - 14:16

I do need the VLAN to be access mode as well, as the AP needs to be on VLAN 20 to get the correct DHCP IP address from the gateway.

glen.grant Wed, 07/23/2008 - 15:33

It won't be in access mode if you trunk it but that doesn't matter because vlan 20 is trunked to the switch along with whatever other vlan you create. The vlan 20 tag gets stripped at the switch which passes it along to the dhcp server.

jerrysafetynet Wed, 07/23/2008 - 18:33

Thanks for the reply's. I need the AP's in their own VLAN's, which I made VLAN 20. When the AP's boot up, they will be in VLAN 20, and when they come across on VLAN 20, they will pull from the correct DHCP scope, based on that VLAN. Next, I've created an egress VLAN of 50 on the AP's. When the users connect to the AP, they will traverse the switches with VLAN 50, and pull from a differnet DHCP scope based on that VLAN. So I need the port to kind of do both, access and trunk, is this possible?

jerrysafetynet Thu, 07/24/2008 - 05:28

I tried "tlohumi"'s suggestion. Setting the native VLAN did work for getting the AP to show up on that VLAN, but I need the AP on one VLAN, and the users connecting to the AP on another VLAN that is provided by the AP.

Actions

This Discussion