Switch Port vioce Vlan not getting IP address

Unanswered Question
Jul 24th, 2008

Hello i have a 3750 switch trying to connect a 7912 phone to the voice switch port however it will not obtain IP address on the the voice vlan. I am confuse why it would not obtain IP address to register. please check config of switch and router VLAN 35 is voice vlan.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Thu, 07/24/2008 - 07:41

First of all, can we assume that dhcp is working for other vlans (vlan 10 for example)

If this is the case then:

1: The dhcp server on 10.0.20.21 may not have a scope for vlan 35.

2: The dhcp server on 10.0.20.21 might not have a route to vlan 35.

As you are also having vlan30 as voice vlan, both scenario's are real possibilities.

Otherwise, you could do some basic troubleshooting and verify that the dhcp server is reachable from int vlan 35 and that dhcp requests are ariving at the server.

regards,

Leo

damrut5763 Thu, 07/24/2008 - 09:20

Ok the DHCP is working that not a problem the 30 voice vlan on the switch doesn't have a dhcp scope assign to it so there is no information for that vlan I can delete it. And i can get to the 35 voice vlan from the server however this is the rror i am getting:

14:43:04.738: DHCPD: Forwarding reply on numbered intf

*Jul 24 14:43:04.738: DHCPD: broadcasting BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:43:12.602: DHCPD: Sending notification of DISCOVER:

*Jul 24 14:43:12.602: DHCPD: htype 1 chaddr 0015.f97e.2f6e

*Jul 24 14:43:12.602: DHCPD: remote id 020a00000a080a010100000a0000

*Jul 24 14:43:12.602: DHCPD: circuit id 00000000

*Jul 24 14:43:12.602: DHCPD: setting giaddr to 10.8.10.1.

*Jul 24 14:43:12.602: DHCPD: BOOTREQUEST from 0100.15f9.7e2f.6e forwarded to 10.0.20.21.

*Jul 24 14:43:12.706: DHCPD: forwarding BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:43:12.710: DHCPD: Forwarding reply on numbered intf

*Jul 24 14:43:12.710: DHCPD: broadcasting BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:43:16.602: DHCPD: Sending notification of DISCOVER:

*Jul 24 14:43:16.602: DHCPD: htype 1 chaddr 0015.f97e.2f6e

*Jul 24 14:43:16.606: DHCPD: remote id 020a00000a080a010100000a0000

*Jul 24 14:43:16.606: DHCPD: circuit id 00000000

*Jul 24 14:43:16.606: DHCPD: setting giaddr to 10.8.10.1.

*Jul 24 14:43:16.606: DHCPD: BOOTREQUEST from 0100.15f9.7e2f.6e forwarded to 10.0.20.21.

*Jul 24 14:43:16.750: DHCPD: forwarding BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:43:16.750: DHCPD: Forwarding reply on numbered intf

*Jul 24 14:43:16.750: DHCPD: broadcasting BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:43:24.606: DHCPD: Sending notification of DISCOVER:

*Jul 24 14:43:24.606: DHCPD: htype 1 chaddr 0015.f97e.2f6e

*Jul 24 14:43:24.606: DHCPD: remote id 020a00000a080a010100000a0000

*Jul 24 14:43:24.606: DHCPD: circuit id 00000000

*Jul 24 14:43:24.606: DHCPD: setting giaddr to 10.8.10.1.

*Jul 24 14:43:24.606: DHCPD: BOOTREQUEST from 0100.15f9.7e2f.6e forwarded to 10.0.20.21.

*Jul 24 14:43:24.770: DHCPD: forwarding BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:43:24.770: DHCPD: Forwarding reply on numbered intf

*Jul 24 14:43:24.770: DHCPD: broadcasting BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:47:26.354: DHCPD: Sending notification of DISCOVER:

*Jul 24 14:47:26.354: DHCPD: htype 1 chaddr 0015.f97e.2f6e

*Jul 24 14:47:26.354: DHCPD: remote id 020a00000a080a010100000a0000

*Jul 24 14:47:26.354: DHCPD: circuit id 00000000

*Jul 24 14:47:26.374: DHCPD: Forwarding reply on numbered intf

*Jul 24 14:47:32.358: DHCPD: Sending notification of DISCOVER:

*Jul 24 14:47:32.358: DHCPD: htype 1 chaddr 0015.f97e.2f6e

*Jul 24 14:47:32.358: DHCPD: remote id 020a00000a080a010100000a0000

*Jul 24 14:47:32.358: DHCPD: circuit id 00000000

*Jul 24 14:47:32.358: DHCPD: setting giaddr to 10.8.10.1.

*Jul 24 14:47:32.358: DHCPD: BOOTREQUEST from 0100.15f9.7e2f.6e forwarded to 10.0.20.21.

*Jul 24 14:47:32.526: DHCPD: forwarding BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:47:32.526: DHCPD: Forwarding reply on numbered intf

*Jul 24 14:47:32.526: DHCPD: broadcasting BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:47:44.362: DHCPD: Sending notification of DISCOVER:

*Jul 24 14:47:44.362: DHCPD: htype 1 chaddr 0015.f97e.2f6e

*Jul 24 14:47:44.362: DHCPD: remote id 020a00000a080a010100000a0000

*Jul 24 14:47:44.362: DHCPD: circuit id 00000000

*Jul 24 14:47:44.362: DHCPD: setting giaddr to 10.8.10.1.

*Jul 24 14:47:44.366: DHCPD: BOOTREQUEST from 0100.15f9.7e2f.6e forwarded to 10.0.20.21.

*Jul 24 14:47:44.518: DHCPD: forwarding BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:47:44.518: DHCPD: Forwarding reply on numbered intf

*Jul 24 14:47:44.518: DHCPD: broadcasting BOOTREPLY to client 0015.f97e.2f6e.

*Jul 24 14:47:50.366: DHCPD: Sending notification of DISCOVER:

*Jul 24 14:47:50.366: DHCPD: htype 1 chaddr 0015.f97e.2f6e

*Jul 24 14:47:50.366: DHCPD: remote id 020a00000a080a010100000a0000

Justin Brenton Thu, 07/24/2008 - 09:37

Why do you have 2 voice vlans?

In your config you have switchport voice vlan 30 and switchport voice vlan 35?

Please post your whole config.

Regards,

Justin

Edison Ortiz Thu, 07/24/2008 - 09:35

Don't use subinterfaces in switches. You need to use SVI (Switch Virtual Interfaces) instead.

Please replace the following configuration:

interface GigabitEthernet0/1.10

encapsulation dot1Q 10

ip address 10.8.10.1 255.255.255.0

ip helper-address 10.0.20.21

no snmp trap link-status

!

interface GigabitEthernet0/1.22

encapsulation dot1Q 22

ip address 10.8.22.1 255.255.255.0

ip virtual-reassembly

no snmp trap link-status

!

interface GigabitEthernet0/1.35

encapsulation dot1Q 35

ip address 10.8.35.1 255.255.255.0

ip helper-address 10.0.20.21

no snmp trap link-status

with

interface vlan 10

ip address 10.8.10.1 255.255.255.0

ip helper-address 10.0.20.21

interface vlan 22

ip address 10.8.22.1 255.255.255.0

ip virtual-reassembly

!

interface vlan 35

ip address 10.8.35.1 255.255.255.0

ip helper-address 10.0.20.21

interface g0/1

switchport trunk encapsulation dot1q

switchport mode trunk

Also, make sure these vlans exist in the Vlan database by issuing a show vlan command.

Furthermore, make sure you are able to ping 10.0.20.21 (The DHCP server) from this switch. I didn't see any IP routing configuration on this switch and the subnet 10.0.20.0/24 isn't listed anywhere.

HTH,

__

Edison.

damrut5763 Thu, 07/24/2008 - 09:54

Hello edison,

I am doing router on a stick so the first part of the attachment was just showing couple of interfaces on the switch, and the second part of the attachment was the router config. I have other rouers configured this way however they have CME on them and it works fine. This particular router doesn't have CME so i am going back to a server over my tunnel bought I can't get an IP address assign to my voice vlan.

Edison Ortiz Thu, 07/24/2008 - 10:35

I noticed some configuration errors that need to be corrected.

Your switch has

interface Vlan1

ip address 10.8.1.2 255.255.255.0

while your router has

interface GigabitEthernet0/1.10

encapsulation dot1Q 10

ip address 10.8.10.1 255.255.255.0

ip helper-address 10.0.20.21

no snmp trap link-status

The router is riding subnet 10.8.10.0/24 on Vlan 10 while the switch is using Vlan 1.

Create an interface for Vlan 10 in the switch and migrate the IP address there. Also, make sure IP routing is disable no ip routing. I also recommend migrating from router-on-a-stick to inter-vlan routing in the switch. Much better performance.

The initial DHCP packet is sent via the access vlan (Vlan 10), can you verify the DHCP server is receiving such packet by looking at its log?

I didn't see Vlan 30 in the router, I saw Vlan 35 subinterface. How are you planning to route the Voice traffic w/o a L3 interface?

__

Edison.

Actions

This Discussion