BGP problem with ISP

Answered Question
Jul 24th, 2008
User Badges:

Problem: MPLS connection between our 2 HQ sites is randomly losing BGP neighbor. The neighbor router ID is the same for both sites but the interface IP is different. Our ISP is not being helpful on resolving the problem. I need help to prove this is a ISP problem. Is there a good BGP debug to use that would help detech an error? Below is an output of our log when the error takes place. Any other ideas on why we lose our neighbor connection?


%BGP-5-ADJCHANGE: neighbor 68.139.0.33 Down Peer closed the session

%BGP-5-ADJCHANGE: neighbor 68.139.0.33 Up

Correct Answer by Giuseppe Larosa about 8 years 10 months ago

Hello,

are you using a QoS scheduler to protect BGP traffic ?


if your link is very busy there is a chance that BGP keepalives can be sometimes lost causing this type of problem.


Use the debug commands suggested in the other posts to verify what happens.


hope to help

Giuseppe

Correct Answer by sdoremus33 about 8 years 10 months ago

Also are there any timing issues between you and thne ISP,check bgp timers also as mentioned before

debug ip bgp events


Correct Answer by AJAZ NAWAZ about 8 years 10 months ago

two of the better debug commands for bgp are:


debug ip bgp events

debug ip bgp updates


hth,

Ajaz

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
AJAZ NAWAZ Thu, 07/24/2008 - 08:39
User Badges:
  • Silver, 250 points or more

two of the better debug commands for bgp are:


debug ip bgp events

debug ip bgp updates


hth,

Ajaz

Correct Answer
sdoremus33 Thu, 07/24/2008 - 08:46
User Badges:
  • Bronze, 100 points or more

Also are there any timing issues between you and thne ISP,check bgp timers also as mentioned before

debug ip bgp events


Correct Answer
Giuseppe Larosa Thu, 07/24/2008 - 10:46
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

are you using a QoS scheduler to protect BGP traffic ?


if your link is very busy there is a chance that BGP keepalives can be sometimes lost causing this type of problem.


Use the debug commands suggested in the other posts to verify what happens.


hope to help

Giuseppe

Actions

This Discussion