MWI NOT WORKING AFTER TROUBLESHOOTING

Unanswered Question
Jul 24th, 2008

Hello,

I have trobuehooted the MWI and it is still not working. I have sed the Port monitor to test whether it is working, not responding.

I cant seem to locate where the Digonistic log is for me to see the problem when I run the Mirco trace.

I need help with this guys.

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
thfergus Thu, 07/24/2008 - 13:02

If you have enabled traces, use the Unity Diagnostic Tool to collect select traces. You want to collect diagnostic files under the AvCsMgr, Notifier, Exchange Monitor, and svchost processes

kingsleyn Fri, 07/25/2008 - 00:12

Thanks Thferqus,

I have actually done that and it is telling me failed for the Notifier and the messages are actually hitting the Esxchange but not been notified on the phone.

Which other test or troubleshooting can I do as I have done all in the troubleshooting manual for MWI.

Thanks.

tim.giles Fri, 07/25/2008 - 01:40

This sounds like the usual exchange permissions problem. Have you manually checked the exchange mailboxes to make sure they have the correct permissions applied to them?

Are all subscribers affected or just one's on particular mailstores?

Please rate if useful...

kingsleyn Fri, 07/25/2008 - 05:06

Kingtimst,

I haven't actually tested for all subscribers as it is a new installation and wanted to test two to three phones before making everyone life on it.

What do I need to do to check manually the permission on the exchange mailboxes? Will this solve the problem and make the MWI work?

Thanks alot in advance.

Tray Stoutmeyer Fri, 07/25/2008 - 06:55

Set these Micro Traces....

ExchangeMonitor all

Notifier all

NotifyQ all

Click Start New Log Files on the Diagnostics Tool.

Test MWI by emptying a mailbox of new messages and then leave a new message for that person and wait a few minutes for it to fail. Note the time of the test.

After waiting to confirm failure, go back to the Diagnostic Tool and click the Gather Log Files, use the Select Logs option and pull the AvCsMgr, AvMsgStoreMonitorSvr, and AvNotifierMgr traces for the time of when you set the new logs. What you should look at first is in the AvMsgStoreMonitor and what you are looking for specifically is a statement TABLE_ROW for that user's alias you left a new message for. If you don't see a TABLE_ROW talking about ADDED for the alias of the user you left a new message for, then Exchange's MAPI is not sending any notification of any changes on that user's mailbox which is either a permissions problem mentioned by the previous person or MAPI is a problem. Besides permissions, you may want to refresh the mapi profile from Unity.

To refresh MAPI, go to the registry on Unity by going to Start > Run and typing regedit. Search the registry for Unity System Profile. Find the second instance and make sure under that Profile is a series of folders that have code names that are very long. Delete that whole Unity System Profile folder that has those long folder names in it. Reboot Unity and that registry will be recreated and refresh any corrupt mapi profiles Unity has for your partner Exchange.

Also use this troubleshooting guide readily available on cisco.com. You can search for Unity Troubleshooting Guide and find it pretty easily.

http://www.cisco.com/en/US/docs/voice_ip_comm/unity/405/troubleshooting/guide/ex/ex.html

Here is the specific MWI portion of that guide.

http://www.cisco.com/en/US/docs/voice_ip_comm/unity/405/troubleshooting/guide/ex/tsg_0500.html

Tray

Tray Stoutmeyer Fri, 07/25/2008 - 06:59

This is in response to the question about manually checking/adding permissions on the Exchange mailboxes/mailstore....

In Exchange System Manager, right click the top tier (the root, it's usually a domain name of some kind) and choose the Delegate Control option. Once Delegate Control is open, make sure that UnityInstall and UnityDirSvc are in there with the permissions mentioned in the pop up that comes up after running permissions wizard. Typically UnityDirSvc is read only and UnityInstall is Admin or Full Admin. UnityDirSvc can also be an admin but it depends on what you are going to do with users on Unity and how you are going to administer and/or add them. Again, refer to the html page the pops up after you run permissions wizard as it details that step in the process for Exchange permissions. If UnityMsgStoreSvc is in the delegate control, remove it as it doesn't belong in there at all.

Tray

Actions

This Discussion