Access Server got Stucked

Unanswered Question
Jul 24th, 2008

Hello All,

For a reason i can not understand my router 2511 just got stucked as seen in the following output. Pressing enter to proceed yield no result.

I trust that looking at this config, someone will be able to help me out, even if i have to loose the current config to mount a new IOS i don't mind.

Thank you all as usual.



16384K bytes of processor board System flash (Read ONLY)

*Mar 1 00:00:10.987: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up

*Mar 1 00:00:10.991: %LINK-3-UPDOWN: Interface Serial0, changed state to down

*Mar 1 00:00:11.359: %LINK-3-UPDOWN: Interface Serial1, changed state to down

*Mar 1 00:00:30.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, chan

ged state to down

*Mar 1 00:00:35.923: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down

*Mar 1 00:00:36.743: %LINK-5-CHANGED: Interface Serial0, changed state to administratively down

*Mar 1 00:00:37.155: %LINK-5-CHANGED: Interface Serial1, changed state to administratively down

*Mar 1 00:00:37.359: %SYS-5-CONFIG_I: Configured from memory by console

*Mar 1 00:00:37.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

*Mar 1 00:00:40.599: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down

*Mar 1 00:01:21.323: %SYS-5-RESTART: System restarted --

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-IS-L), Version 12.3(5b), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Fri 16-Jan-04 01:32 by kellythw

*Mar 1 00:01:21.327: %SNMP-5-COLDSTART: SNMP agent on host Access-Server is undergoing a cold start

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Fri, 07/25/2008 - 02:15

As far as I can see, this is a fairly normal reboot. Your console might be stuck.

Login to the box via telnet and do a "clear lin con 0".

Also, note that this is not the device's configuration, just the log.


Leo

newnetman Sun, 07/27/2008 - 17:04

Hello Leo,

I'm most grateful for your response. Unfortunately, i cannot do any "clear con 0" because the system is not even responsive to ordinary pressing enter on the keyboard.

I know this not the config but the log, but from this stage what else can i do to gain back the control of the system even if i have to re-install the IOS or loose and current config?.

I have tried changing the line speed and the bit rate hoping that will help but to no avail.

Hope someone can still help me further?.

Regards

rajib_das Sun, 07/27/2008 - 23:48

i think you have problem in scroll lock.


so, you can press the "scrool lock" then press enter .


rajib

newnetman Mon, 07/28/2008 - 04:50

Rajib,

Thanks for the response. But the problem is not related to scroll locked, because i pressed it countless of time on and off but yield no result.

Any further?.

Regards

newnetman Tue, 07/29/2008 - 07:00

Hello,

I am still appealing to anyone who has idea on how to go about resolving my problem with this 2511, it has paralized my lab activities for too long.

From where this device is stucked (look at my first post), What can i do to gain access again to the system at least to reinstall if that is going to be the last option?.

Please note, the system always bootup normally but hanged at where it says "cold start........" press enter to start, from here it becomes unresponsive any key pressed.

Thanking you all and looking forward to further help,

Regards

newnetman Tue, 07/29/2008 - 10:05

Hello,

many thanks for your suggestion. Unfortunately the router does not even respond to the BREAK key.

Any further help shall be hugely appreciated.

Thanks

newnetman Tue, 07/29/2008 - 15:44

Hello All,

Still on the same problem but have been able to gain temporary access to the router now with the control + break key and changed the (config-reg)TO o/r 0x2142. Which now presents me with Router(boot)>

How can i proceed from here?, knowing well that my aim is not for password recovery.

Thanking you all in advance for your usual assistance,

Thanks

InternetB Tue, 07/29/2008 - 16:49

Hello Newnetman,

Have you changed any settings prior to rebboting your access server ? ie) did you do an IOS upgrade on it. Because something must have triggered it not to boot properly in the first place ....


Thank you,


Cheers,

- InternetB -

vaisharm Tue, 07/29/2008 - 23:09

The idea was only to check if the router boots up fine without the config. Although the router should have taken you back to the router prompt, its strange that its in boot mode. Does the router hang in the boot mode as well?


Erase the current configuration from boot mode (write erase or erase nvram:) and then change the configuration register back to 0x2102 from ROMmon.


Now see if the router boots up fine. If you still see the same problem, unplug all the cables from the router (except, the console cable and the power cord ofcourse) and reboot. If its the same again, then its a HW failure for sure.


~Vaibhav

newnetman Wed, 07/30/2008 - 13:07

Guys,

After a lengthy workaround on this router, i was able to get to this point as shown by the following output. How can i proceed to get myself out of this interface?.



Router2511(boot)#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Ethernet0 unassigned YES not set up down

Serial0 unassigned YES not set administratively down down

Serial1 unassigned YES not set administratively down down

Router2511(boot)#


Please your urgent help shall be appreciated.

Thanks

vaisharm Wed, 07/30/2008 - 23:35

Please provide the following outputs:


show flash:

show version


~Vaibhav

newnetman Thu, 07/31/2008 - 03:46

vaisharm,

Thanks once again for your help. Here is the output of the sh flash though it does not accept it with ":" colon.

Router(boot)>sh flash


System flash directory, partition 1:

No files in System flash

[0 bytes used, 8388608 available, 8388608 total]

8192K bytes of processor board System flash (Read/Write)

System flash directory, partition 2:

No files in System flash

[0 bytes used, 8388608 available, 8388608 total]8192K bytes of processor board System flash (Read/Write)

Router(boot)>


HERE IS THE SH VER OUTPUT

Router(boot)>sh ver

Cisco Internetwork Operating System Software

IOS (tm) 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (f

c1)

Copyright (c) 1986-1996 by cisco Systems, Inc.

Compiled Fri 27-Dec-96 17:33 by loreilly

Image text-base: 0x01010000, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE

Router uptime is 3 minutes

System restarted by power-on

Running default software


cisco 2511 (68030) processor (revision L) with 14336K/2048K bytes of memory.

Processor board ID 06168381, with hardware revision 00000000

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

1 Ethernet/IEEE 802.3 interface.

2 Serial network interfaces.

16 terminal lines.

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash partition 1 (Read/Write)

8192K bytes of processor board System flash partition 2 (Read/Write)

Configuration register is 0x2142

Router(boot)>

Will be looking forward to your usual help.

Thanks

vaisharm Thu, 07/31/2008 - 09:51

Hi,


You may try this..


router(boot)>enable

router(boot)#wr erase

router(boot)#config term

config-reg 0x2102


Now assign an ip address on the ethernet interface on the router. Connect you router to your PC using a cross-cable and run a tftp server on it. The IOS image that you want to copy on to the router should be in the default directory of the tftp server. After you have ensured two-way connectivity between the router and the PC, issue the following command:


router(boot)# copy tftp flash:

OR (try the following command only if the above command does not work)

router(boot)# copy tftp flash:1:


IP address or name of remote host ? x.x.x.x -> TFTP server IP address

Name of tftp filename to copy into flash []? IOS_image_name.bin


copy IOS_image_name.bin from x.x.x.x into flash memory? [confirm]


xxxxxxxx bytes available for writing without erasure.


erase flash before writing? [confirm]


Clearing and initializing flash memory (please wait)####...


Loading from x.x.x.x: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


!!!!!!!!!!!!!... [OK - xxx/yyy bytes]


Verifying checksum...


VVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVV

VVVVVVV...


Flash verification successful.



router(boot)#show flash: -> confirm that the file is there.

router(boot)# reload



Let us know how it goes.


HTH

~Vaibhav

newnetman Thu, 07/31/2008 - 11:39

Vaibhav,

I'm delighted with your relentless effort to assist me. Unfortunately i could not perform the mentioned action because i do not have a transceiver to convert my ethernet port. I hope you know that the 2511 ethernet requires a transceiver to connect to the PC?. (Except you know of any other way without a transceiver).

Though without any major change to the configuration, isn't there any way i can get out of this config because i have the suspicion (though not a good technical language) that the sysytem is now working ok, only need to get out of this mode

Router(boot)> Any idea on how to come out of the boot mode?.

Many thanks for your time.

Regards

InternetB Thu, 07/31/2008 - 18:45

Hello Newnetman,

You can put the IOS to the 2511 via a xmodem transfer.


Here is how to do it :-


Boot into rommon mode.

Change the console rate to 115200 (otherwise it'll take a lot longer).

You'll have to restart HyperTerm (or whatever program your using) to

match the 115200 console rate.

Transfer the file via HyperTerm using xmodem.

It may seem like it's not doing anything after it's done transferring but

the checksum on the image transferred may take a while. (You'll see the hex

numbers slowly count upwards).

When it's done reload the router, providing it's a supported IOS for

that model and you have sufficient flash and ram, it should be

successful.


This URL has step by step guide to do an IOS upgrade via xmodem.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/prod_release_note09186a0080081127.html#10044

under the heading 'Installing the Router Software by Using the Console or Auxiliary Port'.


This will do it .... :).


Good luck ...


Cheers,

- InternetB -


p.s. Rate the post if it is of help to you.

newnetman Fri, 08/01/2008 - 00:33

Hello,

I am very grateful for your continual assistance. Hopefully this will be the last question on this subject. How can i get out of this mode to "rommon mode"?. I am perfectly confident about xmodem. But the sytem won't let me into xmodem. (from here Router(boot)>)

Thanking you all

InternetB Fri, 08/01/2008 - 00:39

Well since you do not have any image in flash, try reloading the router or off and on the router. This should take you to rommon mode.


Cheers,

- InternetB -

newnetman Fri, 08/01/2008 - 01:27

Hello

Thanks once again. Rebooting i have done countless of times but always return to the same boot mode. My suspicion is that the flash is partially erased or something in that line.

Have a look at the bootup.

Cisco Internetwork Operating System Software

IOS (tm) 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (f

c1)

Copyright (c) 1986-1996 by cisco Systems, Inc.

Compiled Fri 27-Dec-96 17:33 by loreilly

Router(boot)>



It also says something like at the startup. (too large to paste all here).

Notice: NVRAM invalid, possibly due to write erase

newnetman Sat, 08/02/2008 - 12:59

Hello All,

I'm very sorry still bothering you all for this same "insane" problem with my 2511.

This is where i am now.


System Bootstrap, Version 11.0(10c), SOFTWARE

Copyright (c) 1986-1996 by cisco Systems

2500 processor with 14336 Kbytes of main memory

>


I wonder if anyone could help further?, on how to get to the rommon mode from here in order to be able to reinstall the IOS. All i need is how to get to the ROMMON, please be informed that i have tried "config-register 0x0" and reloaded yet doesn't make any progress. always bringing me back to the same mode as shown above.

Urgetly awiting your assistance.

Thanks

vaisharm Sun, 08/03/2008 - 03:01

Hi,


You had mentioned that you do not have an AUI connector for the ethernet port and so you won't be able to use it. I see that there are serial interfaces as well on your router. Is it poosible for you to connect your AS2511 back-to-back to another router using the serial interface? If yes, then let me know which router can you connect it to and then we can try to recover the 2511.


~Vaibhav

Actions

This Discussion