Device Unregistering in CCM

Unanswered Question
Jul 25th, 2008

I get a bunch, between 10 and 20, phone that unregister. If I look in the CCM event logs under application I see the following...

Error: DeviceUnregistered - Device unregistered.

Device name.: SEPXXXXXXXXXXXX

Device IP address.: 10.XX.XX.XX

Device type. [Optional]: 308

Device description [Optional].: San Conference room-xxxxxxxx

Reason Code [Optional].: 8

App ID: Cisco CallManager

Cluster ID: NPPUB-Cluster

Node ID: 10.XX.XX.XX

Explanation: A device that has previously registered with Cisco CallManager has unregistered. This event may be issued as part of normal unregistration event or due to some other reason such as loss of keepalives.

Recommended Action: No action is required if unregistration of this device was expected..

I looked up reason code 8 and it says

CallControlInitFailed

What can I look at to correct this problem or what would or could be causing this?

Mike

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (7 ratings)
Loading.
Ayodeji oladipo... Fri, 07/25/2008 - 03:51

Is this a stand alone cluster or do you have a secondary server in your cluster.

If you hav a backup server, look into the callmanger trace, you will see the reason why the phone unregistered, because it will attempt to register with teh secondary server when it unregisters from the primary and before it registers it will send a station larm which will tell you the reson why it unregistered from the primary server..

burleyman Fri, 07/25/2008 - 04:03

It is stand alone. Where are the callmanager traces located? I am trying to see if this is a network problem or call manager problem or something else.

Mike

Ayodeji oladipo... Fri, 07/25/2008 - 04:33

The reason code you are seeing (8) indicates that the device initiated a reset.

In the past where this has happened to me, this has been due to a router interface connecting the callmanager and IP phone resetting itself, hence the ip phone looses tcp connection to the callmanager.

This is definitely a network issue.

Start by looking at the link between your i p phones and callmanger..look at the router interface, if this applies and check to see that there are no resets on the interfcae

burleyman Fri, 07/25/2008 - 04:51

Phones connect to a 4506 catalyst switch and then to a 2821 router which has a P2P full T-1 directly back to the main site and a MPLS connection again to the main site. The P2P connects to a 3845 router and the MPLS also connects to a second 3845 router. I checked the switch port the phone connects to and there are no errors since last interface clearing ove 11 weeks ago. I checked the Interfaces on both routers and there were no interface resets but there were some output drops but the clear interfaces was over 20 weeks ago, so I just cleared the interface counters and I will monitor. I am also getting a reason code of 9 on some of the phones as well. Any thing else I should look at?

Mike

burleyman Fri, 07/25/2008 - 04:24

I am sorry wrong info...there is a secondary server. Where are the logs located?

Mike

Ayodeji oladipo... Fri, 07/25/2008 - 05:06

ccm traces are located at c:/program files/cisco/trace/ccm.

You will use the devices mac address to search for them and the lrms they generate when they try to register with the secondary server. you can checn your event viewer ont he 2nd server to know if they attempt to register with it

burleyman Fri, 07/25/2008 - 06:45

I see this error message in the event log on the secondary server...

Error: DeviceTransientConnection - Transient connection attempt.

Connecting Port: 0

Device name [Optional].:

Device IP address.: 10.xx.xx.xx

Device type. [Optional]: 255

Reason Code [Optional].: 6

App ID: Cisco CallManager

Cluster ID: NPPUB-Cluster

Node ID: xx.xx.xx.xx

Explanation: A connection was established and immediately dropped before completing registration. Incomplete registration may indicate a device is rehoming in the middle of registration. The alarm could also indicate a device misconfiguration, database error, or an illegal/unknown device trying to attempt a connection.

Recommended Action: No action is required if this event was issued as a result of a normal device rehome..

Ayodeji oladipo... Fri, 07/25/2008 - 06:57

This exactly what I expereinced. What is happening is this..The TCP connection between callmanager and IP phone is flapping. So when the IPphone sunregisters and tries to register to the secondary server, the tcp connection on the primary comes backup then th phone immediately switches back to the secondary.

You have a network problem between your ccm and Ip phones. you need to loo into that. I am 100% sure this is your problem.

If you know how to use packet sniffer like wireshark, you can use this to see where your tcp is getting broken..

pls rate useful posts!

burleyman Fri, 07/25/2008 - 07:57

I will give it a shot. Is there anything specific I should start with? Also, why is it only 1 or 2 phones and not the whole office?

Mike

Ayodeji oladipo... Fri, 07/25/2008 - 08:01

I didnt know it was one or two phones. I thought it was a section of your office. In that case you will have to look at the phones themselves. To know if its a firmware problem on thephones, I will replace the phones with new phones then observe it

dhccoid.com Fri, 07/25/2008 - 13:22

I agree with aokanlawon on this, in my experience this is nearly always a network problem, usually an Duplex mismatch somewhere between the Callmanager and the Phone. Check every port between the two, use show interface commands to check, do not rely on just looking at configs of the ports.

burleyman Mon, 07/28/2008 - 04:02

Thanks for your help. I checked all the duplex settings and all is good. I also have been monitoring the MPLS and P2P connections and I did find some drops and a couple other error and I am looking into those.

Thanks for your help.

Mike

Actions

This Discussion