GUI for Cisco routers

Unanswered Question
Jul 25th, 2008

I have several Cisco routers in my environment. Models are as follows:




Several 2651's

Are any of these managable by way of a GUI?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Sean McCoy Fri, 07/25/2008 - 07:00


Thanks. I need to enable HTTP/HTTPS on the routers. For some reason, SDM will not accept my telnet password (the same password does work with a normal telnet session with router).


Mark Yeates Fri, 07/25/2008 - 07:28


You will need to enable HTTP/HTTPS for SDM to work. Please see the help.htm on the SDM zip file you downloaded to properly open your router

for SDM management access. If you have any issues feel free to ask.


Sean McCoy Fri, 07/25/2008 - 07:42


Is it possible the router image is not supported? I followed the instructions to create a user with privilege level 15 and it still will not accept the password. The new user and password does work with a normal telnet session.


Mark Yeates Fri, 07/25/2008 - 08:12

What version IOS are you using? There are minimum requirements for SDM. Are you inputting the username like this?

username mark privilege 15 password cisco123


Brian Meade Mon, 07/28/2008 - 12:52

You need to enable local authentication for http.

Router(config)#ip http authentication local

Sean McCoy Tue, 07/29/2008 - 04:49

Thank you to everyone for your help. My IOS version 12.1(5)T12. I have tried everything at this point and SDM will still not accept the telnet password.

Goutam Sanyal Tue, 07/29/2008 - 22:59


Before that you please put in the picture that "are you using any tacacs+/radius for accessing the Router?" If not, you just add the following with my previous command.


aaa authentication login default local

aaa authorization exec default local




Goutam Sanyal Mon, 07/28/2008 - 21:48


As per my knowledge the following will be sufficient to access SDM/HTTP/HTTPS

#ip http server

#ip http authentication local

#ip http secure-server

#ip http timeout-policy idle 5 life 86400 requests 10000

#username [name of user] privilege 15 secret [password]




This Discussion