Ruteo entre VLAN capa 3

Unanswered Question
Jul 25th, 2008
User Badges:

Hola, ya he estado leyendo acerca de este problema y he hecho todo lo que dicen para solucionarlo pero sigo igual.

Mi problema es de que las dos Vlan que tengo no se ven con un ping.

Cuando yo escribo el comando


Switch#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


C 192.168.1.0/24 is directly connected, Vlan10

C 192.168.2.0/24 is directly connected, Vlan20


Me a parece que estan conectadas pero sigo sin que se pueden ver

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 07/25/2008 - 12:47
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Perdona mi espanol, no es tan bueno escrito.


Tienes que modificar las unidades conectada a este switch can la IP de su Vlan.


Por ejemplo, unidades in Vlan 10, tiene que apuntar a la IP 192.168.1.1 como su default-gateway. Lo mismo con unidades in Vlan 20.


Una vez hasga eso, debe de funcionar.


__


Edison


Fernando de Jes... Fri, 07/25/2008 - 13:59
User Badges:

Gracias por responder me


Asi lo tengo, creo que esta configurado como tu lo dices


Switch#show runn

Building configuration...


Current configuration : 1458 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

no aaa new-model

switch 1 provision ws-c3750-24ts

system mtu routing 1500

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet1/0/1

switchport access vlan 10

!

interface FastEthernet1/0/2

!

interface FastEthernet1/0/3

switchport access vlan 20

!

interface FastEthernet1/0/4

!

interface FastEthernet1/0/5

!

interface FastEthernet1/0/6

!

interface FastEthernet1/0/7

!

interface FastEthernet1/0/8

!

interface FastEthernet1/0/9

!

interface FastEthernet1/0/10

!

interface FastEthernet1/0/11

!

interface FastEthernet1/0/12

!

interface FastEthernet1/0/13

!

interface FastEthernet1/0/14

!

interface FastEthernet1/0/15

!

interface FastEthernet1/0/16

!

interface FastEthernet1/0/17

!

interface FastEthernet1/0/18

!

interface FastEthernet1/0/19

!

interface FastEthernet1/0/20

!

interface FastEthernet1/0/21

!

interface FastEthernet1/0/22

!

interface FastEthernet1/0/23

!

interface FastEthernet1/0/24

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.1.1 255.255.255.0

!

interface Vlan20

ip address 192.168.2.1 255.255.255.0

!

ip classless

ip http server

!

!

control-plane

!

!

line con 0

line vty 5 15

!

end



Edison Ortiz Fri, 07/25/2008 - 15:00
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Estamos de acuerdo. La parte del switch esta completa. El problema es conectarse de una maquina a otra?


En la maquina, tienes la configuracion del default-gateway apuntando al switch?


Puedes demostrar el IPCONFIG /ALL de la maquinas?


Fernando de Jes... Wed, 07/30/2008 - 11:25
User Badges:

********** VLAN 10 ********

C:\Documents and Settings\Administrador>ipconfig /all


Configuración IP de Windows


Nombre del host . . . . . . . . . : cta-lizciber62F69B

Sufijo DNS principal . . . . . . :

Tipo de nodo . . . . . . . . . . .: difusión

Enrutamiento habilitado. . . . . .: No

Proxy WINS habilitado. . . . . : No


Adaptador Ethernet Conexiones de red inalámbricas :


Estado de los medios. . . .: medios desconectados

Descripción. . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network

Connection

Dirección física. . . . . . . . . : 00-0E-35-8C-53-5D


Adaptador Ethernet Conexión de área local :


Sufijo de conexión específica DNS :

Descripción. . . . . . . . . . . : NIC Fast Ethernet PCI Familia RTL813

9 de Realtek

Dirección física. . . . . . . . . : 00-C0-9F-62-F6-9B

DHCP habilitado. . . . . . . . . : No

Dirección IP. . . . . . . . . . . : 192.168.1.103

Máscara de subred . . . . . . . . : 255.255.255.0

Puerta de enlace predeterminada : 192.168.1.1


************* VLAN 20 **************


C:\Users\rojaspher>ipconfig /all


Configuración IP de Windows


Nombre de host. . . . . . . . . : Toshiba

Sufijo DNS principal . . . . . :

Tipo de nodo. . . . . . . . . . : híbrido

Enrutamiento IP habilitado. . . : no

Proxy WINS habilitado . . . . . : no

Lista de búsqueda de sufijos DNS: ybag.cucea


Adaptador LAN inalámbrico Conexión de red inalámbrica:


Sufijo DNS específico para la conexión. . : ybag.cucea

Descripción . . . . . . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965A

GN

Dirección física. . . . . . . . . . . . . : 00-13-E8-2C-2B-23

DHCP habilitado . . . . . . . . . . . . . : sí

Configuración automática habilitada . . . : sí

Vínculo: dirección IPv6 local. . . : fe80::1c99:ec93:dc45:5107%9(Preferido)

Dirección IPv4. . . . . . . . . . . . . . : 172.16.3.191(Preferido)

Máscara de subred . . . . . . . . . . . . : 255.255.252.0

Concesión obtenida. . . . . . . . . . . . : miércoles, 30 de julio de 2008 10

:29:45 a.m.

La concesión expira . . . . . . . . . . . : miércoles, 30 de julio de 2008 07

:31:32 p.m.

Puerta de enlace predeterminada . . . . . : 172.16.0.1

Servidor DHCP . . . . . . . . . . . . . . : 172.16.0.9

IAID DHCPv6 . . . . . . . . . . . . . . . : 218108904

Servidores DNS. . . . . . . . . . . . . . : 148.202.23.101

148.202.23.1

NetBIOS sobre TCP/IP. . . . . . . . . . . : habilitado


Adaptador de Ethernet Conexión de área local:


Sufijo DNS específico para la conexión. . :

Descripción . . . . . . . . . . . . . . . : Realtek RTL8101 Family PCI-E Fast

Ethernet NIC (NDIS 6.0)

Dirección física. . . . . . . . . . . . . : 00-1B-24-56-1D-BB

DHCP habilitado . . . . . . . . . . . . . : no

Configuración automática habilitada . . . : sí

Vínculo: dirección IPv6 local. . . : fe80::b476:2c76:2005:bf26%8(Preferido)

Dirección IPv4. . . . . . . . . . . . . . : 192.168.2.102(Preferido)

Máscara de subred . . . . . . . . . . . . : 255.255.255.0

Puerta de enlace predeterminada . . . . . : 192.168.2.254

Servidores DNS. . . . . . . . . . . . . . : fe80::b476:2c76:2005:bf26%8

NetBIOS sobre TCP/IP. . . . . . . . . . . : habilitado



C:\Users\rojaspher>


Edison Ortiz Wed, 07/30/2008 - 11:34
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Vlan 10:


Sufijo de conexión específica DNS :

Descripción. . . . . . . . . . . : NIC Fast Ethernet PCI Familia RTL813

9 de Realtek

Dirección física. . . . . . . . . : 00-C0-9F-62-F6-9B

DHCP habilitado. . . . . . . . . : No

Dirección IP. . . . . . . . . . . : 192.168.1.103

Máscara de subred . . . . . . . . : 255.255.255.0

Puerta de enlace predeterminada : 192.168.1.1


Esa esta bien


Vlan 20:


Sufijo DNS específico para la conexión. . : ybag.cucea

Descripción . . . . . . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965A

GN

Dirección física. . . . . . . . . . . . . : 00-13-E8-2C-2B-23

DHCP habilitado . . . . . . . . . . . . . : sí

Configuración automática habilitada . . . : sí

Vínculo: dirección IPv6 local. . . : fe80::1c99:ec93:dc45:5107%9(Preferido)

Dirección IPv4. . . . . . . . . . . . . . : 172.16.3.191(Preferido)

Máscara de subred . . . . . . . . . . . . : 255.255.252.0

Concesión obtenida. . . . . . . . . . . . : miércoles, 30 de julio de 2008 10

:29:45 a.m.

La concesión expira . . . . . . . . . . . : miércoles, 30 de julio de 2008 07

:31:32 p.m.

Puerta de enlace predeterminada . . . . . : 172.16.0.1

Servidor DHCP . . . . . . . . . . . . . . : 172.16.0.9

IAID DHCPv6 . . . . . . . . . . . . . . . : 218108904

Servidores DNS. . . . . . . . . . . . . . : 148.202.23.101

148.202.23.1

NetBIOS sobre TCP/IP. . . . . . . . . . . : habilitado


Adaptador de Ethernet Conexión de área local:


Sufijo DNS específico para la conexión. . :

Descripción . . . . . . . . . . . . . . . : Realtek RTL8101 Family PCI-E Fast

Ethernet NIC (NDIS 6.0)

Dirección física. . . . . . . . . . . . . : 00-1B-24-56-1D-BB

DHCP habilitado . . . . . . . . . . . . . : no

Configuración automática habilitada . . . : sí

Vínculo: dirección IPv6 local. . . : fe80::b476:2c76:2005:bf26%8(Preferido)

Dirección IPv4. . . . . . . . . . . . . . : 192.168.2.102(Preferido)

Máscara de subred . . . . . . . . . . . . : 255.255.255.0

Puerta de enlace predeterminada . . . . . : 192.168.2.254

Servidores DNS. . . . . . . . . . . . . . : fe80::b476:2c76:2005:bf26%8

NetBIOS sobre TCP/IP. . . . . . . . . . . : habilitado


Esta maquina tiene dos "Puerta de enlace predeterminada" y una de ellas pertenece a Vlan 20 (192.168.2.x) pero no es correcta.


El IP correcto is 192.168.2.1 no 192.168.2.254


Ademas, debes the eliminar la coneccion del wireless para que esto trabaje.



HTH,


__


Edison.

Fernando de Jes... Wed, 07/30/2008 - 12:12
User Badges:

Ya modifique la puerta de enlace de la maquina que pertenece a la VLan20, tambien ya apague el Wireless.


Le hice un ping de la maquina de la VLAN20 a la maquina de la VLAN 10 y si funciono, pero el al hacerlo de la maquina de la Vlan10 a la Vlan20 no funciona, no entiendo porque

Edison Ortiz Wed, 07/30/2008 - 14:01
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Chequea que la maquina no tenga el firewall prendido.


Si te he ayudado por favor no olvide de marcar esta discusion como resuelto.


Gracias.


__


Edison.

Actions

This Discussion