BGP-

Unanswered Question
Jul 28th, 2008
User Badges:

Hi,

I have 3 routers. A has ebgp connection with B. B has ebgp connection with C. It means, router A is not directly connected with C. The problem is , I am unable to ping C from A & Vice Versa. Please help.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Kevin Dorrell Mon, 07/28/2008 - 01:49
User Badges:
  • Green, 3000 points or more

I'm afraid you will have to give a lot more information. You are really giving us nothing to work on.


We need to know what are the addresses you are using, what address you are pinging from, what address you are pinging to, the show ip bgp from each router, and preferably also the configurations of all three routers.


Kevin Dorrell

Luxembourg




Rupesh Kashyap Mon, 07/28/2008 - 01:56
User Badges:

Router A- S0/0- 10.1.1.1/24

Router B- S0/0- 10.1.1.2/24

Router B- S0/1- 20.1.1.2/24

Router C- S0/1- 20.1.1.3/24


1. A is connected to B & B is connected to C.

2. In show IP BGP on Router A, I am seeing advertised routes of C.

3. In show IP BGP on Router C, I am seeing advertised routes of A.

4. So there is no problem in the BGP configuration and is working OK. MY only question is , I am unable to ping Router A IP- 10.1.1.1 from C. Same is from C to A.



lee.reade Mon, 07/28/2008 - 02:25
User Badges:
  • Silver, 250 points or more

Hi,


You will probably not have "next-hop-self" configured for the B to A iBGP peer, since B-C is eBGP peer, then the next hop would be C address.


What routers are advertising 10.1.1.0/24 and 20.1.1.0/24?


Give us a show ip bgp from A/B/C.


HTH


LR

Rupesh Kashyap Mon, 07/28/2008 - 02:42
User Badges:

I have configured Next-Hop-Self & no problem in the configuration.


Tell me one thing, Is it possible to ping those ebgp routers who are not directly connected?

guruprasadr Mon, 07/28/2008 - 03:01
User Badges:
  • Gold, 750 points or more

HI Rupeesh, [Pls RATE all informative POST]


Answer to your Question is: YES


Best Regards,


Guru Prasad R

lee.reade Mon, 07/28/2008 - 03:01
User Badges:
  • Silver, 250 points or more

Hi,


Well, aslong as you have the route for it installed in the routing table!


On A, when you do show ip bgp, do you see the network 20.1.1.0/24 via B?


Give us the show ip bg from A and C please.


HTH


LR

Rupesh Kashyap Mon, 07/28/2008 - 03:27
User Badges:

I have config in office.

I have not configured any static route on A for C. It is the reason , I am unable to ping ???


lee.reade Mon, 07/28/2008 - 03:31
User Badges:
  • Silver, 250 points or more

Hi,


Yes it sounds like it,


You do not have to config static routes, instead on B just configure 10.1.1.0 mas 255.255.255.0 and 20.1.1.0 mas 255.255.255.0


This will advertise the 20.1.1.0 net to A and the 10.1.1.0 net to C, so that they will have route to one another.


HTH


LR

guruprasadr Mon, 07/28/2008 - 03:32
User Badges:
  • Gold, 750 points or more

HI Rupeesh, [Pls RATE all informative POST]


If you have configured the BGP Neigbor relationship with the Loopback IP @ Address ensure to add "update-source Loopback0" in the Configuration.


If you have established the E-BGP connection with non-directly connected interface, in this situation, use ebgp-multihop command


Your Router A & Router B Configuration should look like this:


Write a STATIC Route for the Loopback Interface pointing to your WAN Interface.


RTA#

int loopback 0

ip address 150.10.1.1 255.255.255.0


router bgp 100

neighbor 160.10.1.1 remote-as 200

neighbor 160.10.1.1 ebgp-multihop

neighbor 160.10.1.1 update-source loopback 0

network 150.10.0.0

ip route 160.10.0.0 255.255.0.0 1.1.1.2

ip route 160.10.0.0 255.255.0.0 2.2.2.2

RTB#

int loopback 0

ip address 160.10.1.1 255.255.255.0


router bgp 200

neighbor 150.10.1.1 remote-as 100

neighbor 150.10.1.1 update-source loopback 0

neighbor 150.10.1.1 ebgp-multihop

network 160.10.0.0

ip route 150.10.0.0 255.255.0.0 1.1.1.1

ip route 150.10.0.0 255.255.0.0 2.2.2.1


Best Regards,


Guru Prasad R

Actions

This Discussion