1711 etherswitch question

Unanswered Question
Jul 28th, 2008

the other day we were setting up a 1711 for a disaster recovery plan and anyway

we needed a 2 port switch temporarily and only really needed 1 of the prots on the etherswitch permanently

so I figured we should be able to put ports 3 & 4 in a seprate Vlan and leave port 1 in vlan 1 so I did the following

vlan database

vlan 2


conf t

int fa 3

sw acc vlan 2

int fa 3

sw acc vlan 2


but it didn't work

we came up with a workable solution to be corrected soon

but I still would like to figure out why it didn't work

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Edison Ortiz Mon, 07/28/2008 - 06:59

You created the Layer2 Vlan and assigned port membership, but if you needed those workstations to reach devices outside that Vlan, you needed to create a Layer3 interface for Vlan 2.

For instance:

interface vlan 2

ip address x.x.x.x y.y.y.y

and configure the workstations w/ default gateway pointing to Vlan 2



is66rlhntadm Mon, 07/28/2008 - 07:02

no I didn't need vlan2 to have a L3 interface

it was a temp fix to not having a cross-over cable

(just making a 2port L2 switch)

the Co-Lo had their stuff configured wrong

at first they had a trunk port going to our rack

in testing the link (after they made their port an access port) we found that we ether nedded a cross-over adapter or a switch inbetween our router and the Co-Lo's cable and having only brought one stand alone switch with us we were trying to come up with a temp fix that would work till we can get an other switch up there or get them to fix the config

is66rlhntadm Mon, 07/28/2008 - 10:12

what we wanted was to connect their cable to our router but that wouldn't work (I think they already made it a crossover cable so we need to uncross it)

so as it was we needed a switch inbetween out router and their cable

at this point its more ceriosity as to why my temp workaround didn't work as my boss is going up their today with a crimping tool and a few ends to change our end of thier cable to the "A" spec

Edison Ortiz Mon, 07/28/2008 - 11:01

Can you explain in detail "what didn't work" and "what was the workable solution" ?



is66rlhntadm Mon, 07/28/2008 - 12:02

quick topo layout



pluging the Co-Lo's ethernet cable into the on-board Fastethernet port didn't work (not even activity leds)

a testing workaround was to plug the Co-Lo's cable into a switch and then a cable from that into the fa0 port

so as we didn't want to use the same switch for the servers as to link to the Co-Lo we tried

(I know a bit crazy)






the temp(undesirable) solution that quite soon will be changed is

(Co-Lo)-switch-1711-ISA (with the 2 most important servers pluged into the etherswitch and both ports of ISA also pluged into the etherswitch)

the undesirable solution has worked good enough but obviously is not a very good way to do it (well niether is the vlan2 idea but it should have worked)


This Discussion