Unity 4.x to 5.xAD Exchange ON Box with CCM AD Integration

Unanswered Question
Jul 28th, 2008

Has any one done a Unity 4.x to 5.x when exchange & AD on Box when Callmanager is integrated into that AD domain?

I've played with this in the lab and I have not found a doog was to save and restore all the CCM Ad info. The bext I can come up with is to export the user's via BAT and re import.

This will redo all the phone associations, however users will still loose things like fast dials and address books...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
espereir Mon, 07/28/2008 - 16:28

Hello Jeff,

Could you please tell us why you are gong to backup the CCM users through BAT? Are you doing a reinstall on Unity?

Please notice that you do not need to rebuild Unity in order to upgrade to 5.X; so could you please give us additional details about this issue?

Thanks!

Jeff Garner Mon, 07/28/2008 - 16:56

We are going from 4.x on Windows 2000 to 5.x on Windows 2003. In order to do the upgrade you need to reinstall the OS. This will wipe out the AD forest (as this is AD & Exchange all on one box VM install). So once you do the DIRT restore yes you get all the user's back with their Unity / exchange mail boxes, however Callmanager no longer has the phone to user associations. This is the reason to export and re import from BAT. The users will already exist from the Unity restore so the BAT tool will just redo the association.

I played with the LDIFDE or CSVDE tools to export the AD domain and re import, however this did not work either...

(CCM Phone / User associations were ok, however the Unity Dirt resotre had issue exmerge did not run due to the fact that the users were created with no exchange mailboxes).

espereir Tue, 07/29/2008 - 08:02

Hello Jeff,

Thanks for the explanation and since you have CCM integrated to a VMOnly box and you plan to upgrade to Windows 2003, I think that the best way to proceed will be to perform a DiRT and BARS backups and restore.

Just as an FYI, please notice that you do not need to upgrade Windows to 2003 for Unity 5.X to work; as a matter of fact, Unity 5.X supports Windows/Exchange 2000 if you are upgrading from 4.X. However, I think that you want to upgrade in order to extend the Windows support life since 2K3 is going EOL.

Hope it helps!

Actions

This Discussion