Viewmail and Unity in Failover on Unity 5.0

Unanswered Question
Jul 28th, 2008

Can Viewmail for Outlook version 5.00 work with Unity when it is failed over? I recall this being fixed in Viewmail for 4.1(1) but the Viewmail 5.0(1), 5.0(2), and 7.0(2) release notes don't really say if this is fixed or a problem still.

I am planning on trying 7.0(2) viewmail but was just trying to find documentation to confirm that the new viewmail will be transparent to users if unity is in fallback mode or not.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Mon, 07/28/2008 - 12:04

If it was fixed in the versions you looked, it will be included in the 7.x release. In the past, we have gotten around the viewmail issue and Failover using DNS round robin. If the Unity primary was down, DNS would redirect the client to Failover server.

viewmail.companyxyz.com

Erick Bergquist Mon, 07/28/2008 - 23:51

It seems it is broken still.

Installed ViewMail 7.0(2) with Unity 5.0(1) ES30 and the users PC is WinXP and Outlook 2003 and ViewMail 7.0(2) works fine, but when Unity Fails over then it doesn't work. The IP addresses in Viewmail show the failover server but it displays this error message dialog,

"Unknown problems are preventing completion of the call"

ranpierce Tue, 07/29/2008 - 07:19

"Unknown problems are preventing completion of the call"

I have tested vmo when failed over on 5.x and 7.x and it works on both. I think that error is a dcom/MM error.

Randy

Erick Bergquist Tue, 07/29/2008 - 07:28

I also got it to work fine on my lab system. I thought it got away from the DCOM issues after version 4.0(4)? It works fine on primary, bur when unity fails over when they go pull up a VM in outlook and hit play on the VMO Bar it gives this error each and every time. We even had them close outlook and restart it, same thing. Even reboot the users PC.

Is there a certain port or permissions on the PC the user needs for it to work right when unity is in failover?

ranpierce Tue, 07/29/2008 - 07:31

that is a MM error. Media Master control

is dcom enabled on the secondary

when failed over what is the IP or servername in vm options in outlook

Randy

ranpierce Tue, 07/29/2008 - 08:05

My production is 7.02 and I just tested and when I failed over I got the same error.

I went into tools/viewmail options in outlook and the IP is the primary IP

I changed it to the secondary IP and tested. It worked.

I thought this was fixed in previous versions though.

Randy

ranpierce Tue, 07/29/2008 - 08:48

sounds like dns. try pinging the ip and then the servername from the workstation.

also try the servername in the vm options instead of IP

Randy

Actions

This Discussion