Hotmail & MSN

Unanswered Question
Jul 29th, 2008
User Badges:

I am using the following config file for CISCO 1841 router....I can browse internet but my MSN messanger and hotmail is not working.


Paragon>

Paragon>

Paragon>en

Paragon#sh runn

Paragon#sh running-config

Building configuration...


Current configuration : 1344 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Paragon

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

ip name-server x.x.x.x

ip name-server x.x.x.x

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

bba-group pppoe global

!

!

interface FastEthernet0/0

ip address x.x.x.x x.x.x.x

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/50

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp pap sent-username *** password ***

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

no ip http server

no ip http secure-server

ip nat inside source list 101 interface Dialer1 overload

!

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

!

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000


!

webvpn cef

end


Paragon#

Paragon#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tdrais Tue, 07/29/2008 - 07:17
User Badges:
  • Blue, 1500 points or more

The default is to allow any traffic on a interface. Putting a access list in to permit all traffic will not have any effect other than make the router use cpu looking at it.


This problem I suspect is more related to this type of program and issues it has with embedding the pc address in the data stream when the pc is using a private address that will be natted to a public address. Many times options can be changed in the software to tolerate a natted address.


The basic configuration is correct it may just need a static nat but hard to say if both these packages do not run at all.

born2winu2 Tue, 07/29/2008 - 21:54
User Badges:

I think I have to change access-group 101 to 100 or 102....anyways...

can you tell me clearly what you means....

I am not getting you probably.

Warm Regards


tdrais Wed, 07/30/2008 - 05:06
User Badges:
  • Blue, 1500 points or more

The nat you are using only creates entries on traffic that comes from your internal machine as it flows out to a external machine on the internet. Once it is created it will allow traffic to return from the external machine.


If the external machine want to start communication with your machine there is nothing in the router to tell it how to translate the address and ports. You will need to put in static nat entries


ip nat inside source static tcp xxx.xx.x.x ???? interface dialer1 ????


You will need to find the ports for the applications you need.


Now this does not fix the issue that MSN can have. What MSN does is some cases it will put the local address of the machine inside a data packet and send it to the far side. The far side will then use that address to attempt a return session rather than use the address of the session that he received it on.


Not much you can do about the above. These issues have been fixed mostly with option in the software but there is little you can do with a router if the application is being stupid.

Danilo Dy Tue, 07/29/2008 - 07:38
User Badges:
  • Blue, 1500 points or more

try setting the mtu to 1200

ignacio.corral Wed, 08/06/2008 - 03:51
User Badges:

MTU by default to 1500 in dialer 1


you can try this command in interface LAN


interface FastEthernet0/0


ip tcp adjust-mss 1440



Actions

This Discussion