Caller ID issue with MGCP PRI

Unanswered Question
Jul 29th, 2008


I am having an issue with a client of mine. They are running the following

Voice gateway - 2851

CCM - Ver 6

1 PRI from Verizon setup as MGCP on the gateway


Issue - THe outbound caller ID is showing the BTN phone number and not the DiD's we have for this location

I called and spoke with Verizon who says the issue is with our end. Verizon told us we are sending the number type as unknown and it needs to be national.

I looked on our switch and it appears to be configured.

-- Global command


isdn switch-type primary-ni


Controller T1 0/0/0

Framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp


interface Serial0/0/0:23

no ip address

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable


In the above portion of the config, I have sent primary-ni

This is the correct to set the type national correct?

When I do a debug isdn q931 on my gatway and then place a call i get the following

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Calling Party Number i = 0x0181, '7XXXXX7839'

Plan:ISDN, Type:Unknown

Called Party Number i = 0x80, 'XXX3718'

Plan:Unknown, Type:Unknown


I show we are sending the 10 digits. But I am assuming when Verizon stated we need to send the type as national and not unknown its because of

Plan:ISDN, Type:Unknown

Can someone tell me where I need to configure that? I beleive its on the switch and not in CM6.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
csco11063007 Tue, 07/29/2008 - 06:42


Go to your MGCP gateway configuration page in your CCM.There you can find at bootom side where you can change the setting to caling party or called party information inot National.


D0nprintup_2 Tue, 07/29/2008 - 07:09

When I check my gateway and then go into the vwic. The settings for outbound routing is as follows

CAlled party IE number type unknown* - Cisco call manager

Calling party IE number type unknown* - Cisco call manager

Called Numbering Plan* - Cisco Call Manager


Now even though its set on the switch, the CCM will override it and this is why its sending unknown?

So to correct this all i need to do i change - CAlled party IE number type unknown* - Cisco call manager - to national?

csco11063007 Tue, 07/29/2008 - 07:29

Yes,You can change caaling party IE number typr to National.

And do a debug Isdn q931


D0nprintup_2 Wed, 07/30/2008 - 05:45

that worked. Originally I looked at the gateway in call manager but I did not go further to the end points.

I didnt realize it until after you pointed it out. This is MGCP so all the settings on the router are overriden by the call manager.

The problem has been corrected.


Rusty Haferkamp Mon, 09/08/2008 - 08:54

I have a simlar problem. I have updated the MGCP on the CCM to "Calling Party = National" and reset the GW but it is still showing the following on debug isdn q931.

Calling Party Number i = 0x0081, '2zzzzzzzz2'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '7zzzzz2'

Plan:Unknown, Type:Unknown

D0nprintup_2 Mon, 09/08/2008 - 09:09

under gateway/endpoitns where outbound calls you have calling party selection - originator

calling party IE 0 national

Calling Numbering plan - ISDN ?

I would verify with your carrier if those are the correct options.


This Discussion