Multicast issues on LAN and WAN

Unanswered Question
Jul 29th, 2008
User Badges:

Hi all. I was hoping to get some help with this. We have Video Conferencing equipment with multicast streaming capability. We want to use it to multicast a company President's speech in a few months.


For our current issue, I'm only going to focus on our basic network routing structure between the source and our test receivers. The first router hop is a 6509 with MSFC for local VLAN routing, then a 7204VXR router for WAN connectivity that connects to a 7204VXR in our DC office, a 3662 in our nearby phone center. We're trying to confirm streaming to the DC and Phone Center locations first.


I start the streaming and have it using group 224.2.23.209. The initial connection is using a URL to http://10.0.31.3/stream.sdp. If I use QuickTime to open this stream, it works. If I do the same on any machine on a 10.x.x.x network VLAN off of the MSFC. The one exception is the VLAN that uses an IP subnet of 38.233.146.x (relic from pre-NAT days). This subnet is also the one that the 7204 WAN router exists on.


So I can multicast stream across any VLAN on the MSFC except this one.


I think If I can fix the stream problem to that VLAN, I can get the multicast across the WAN working.


On the routers we're using the ip multicast and ip pim sparse-mode configuration commands. And that's about it. I read that we don't need an RP in sparse-mode because the routers should figure out which one needs to be an RP.


It seems like the 7204 and the MSFC will peer with each other. Yet it seems like the 7204 never gets the multicast group joined on it, even when a machine across the WAN requests the stream.


I didn't think multicast was this difficult to configure. I had it working easily between most of the local VLANs using the simple ip multicast and ip pim sparse-mode commands, just not sure why that one VLAN and the WAN are being such a problem.


Any help is appreciated.


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Giuseppe Larosa Tue, 07/29/2008 - 10:04
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello James,

with PIM Sparse mode you need to define the RP.


There are different ways to do this and to propagate this info


the simplest way is manual configuration


on all routers except the RP

put

ip pim rp


where rp-address is a loopback address advertised in the unicast routing protocols


Depending on IOS release the command can be skipped on the RP itself or needs to be defined.


check with sh ip pim rp mapping


Without it can work between vlans of the core C6509 because there is no need to build a spanning tree

When the spanning tree is on more routers the RP helps in the initial building of a shared tree.


Hope to help

Giuseppe


JMakowski Tue, 07/29/2008 - 12:22
User Badges:

Thanks for the info Giuseppe.


I'm a little rusty and don't use loopbacks much in actual practice. Can you expand on what you mean about "where rp-address is a loopback address advertised in the unicast routing protocols"?


Also, is the RP still necessary is Auto-RP is enabled?


Thanks.

nate-miller Tue, 07/29/2008 - 12:36
User Badges:
  • Bronze, 100 points or more

Create a loopback interface-

interface loopback 0

ip address X.X.X.X 255.255.255.255


A /32 bit mask is fine for a loopback. Keep in mind that this loopback addressing can't overlap with anything else in your network. (So if you have a server vlan that's defined as a /24, you can't pick your loopback to be addressed out of this range.)



Once that Loopback is defined, you simply have to drop it into your dynamic routing protocol with the appropriate network statement. (OSPF, EIGRP, RIP, what have you.) Or update all your static routes if that's the way you roll...


Loopbacks area good practice to get into because they can never go down!

Imagine you've got a WAN router with two WAN interfaces, and a LAN interface. When you connect to the box remotely, you're in the habit of telnetting to the LAN ethernet address.

Now let's say the Switch at that site goes down- the LAN link is down, and isn't advertised. Now you can't telnet to that IP address.


Same goes for various permutations of if you're used to connecting to various WAN interfaces.


If you connect to the Looopback, which is dynamically routed... it doesn't matter which permutation of interfaces is up/down, as long as there's some form of connectivity of the box, you know exactly which address you can telnet to. Same goes for sourcing of Syslog, NTP, TACACS, and any other number of services that are hopefully interface agnostic.


Giuseppe Larosa Tue, 07/29/2008 - 12:42
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello James ,


is the RP still necessary is Auto-RP is enabled?


yes, but you need different commands to declare a candidate RP and to define a mapping agent (they can be the same router)


I would suggest you to stay on manual config for the first setup

later you can add complexity to your solution


for the first question you have already received useful information


Best Regards

Hope to help

Giuseppe


JMakowski Wed, 07/30/2008 - 12:51
User Badges:

Thanks a lot for the help. The Loopbacks and defining the RP's on the routers did the trick.


Thank you!!!!

Giuseppe Larosa Wed, 07/30/2008 - 12:58
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello James,

nice to hear that you solved your issue.

Thank for your good remarks.


It is a good practice to report if the suggested solutions work because in this way the case story is completed and is useful for everyone that reads and wants to learn about the subject.


Best Regards

Giuseppe

Actions

This Discussion