Trunk issue

Unanswered Question
Jul 29th, 2008

I have discovered a problem with my newotk on one particular vlan. The problem started

with a dhcp issue. No clients whatsoever could get a ip address from vlan2 on the switch,

but there were no problems with the other vlans. The router itself acts as a dhcp server

for all vlans, including the one i have problems with. Vlan2 has the exact same configuration

as vlan3, and that one i have never had any issues with.

During troubleshooting i connected a client directly to a accessport on the 1812 router, and

voila! It recieved a ip address. This makes me believe that the configuration itself is good.

I have some sort of trunk issue, for the 1812 router and 2960 switch is conencted via a trunk.

Now i borrowed a 1841 router to act as a client. And i discovered a strange thing. First the setup:

Physical setup:

1812(fa2) ----- 2960(fa0/8)

2960(fa0/4) ----- 1841(fa0/0)

Configurations:

1812:

interface FastEthernet2

switchport mode trunk

2960:

interface FastEthernet0/4

switchport mode trunk

1841:

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.100.2.250 255.255.255.0

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 10.100.3.251 255.255.255.0

With this setup i can ping the vlan2 interface (10.100.2.252/24) on the switch from the 1841,

but not the default gateway on the 1812 router for vlan 2 (10.100.2.254/24). But i can however

ping the default gateway for vlan 3 on the router (10.100.3.254/24)!!!

If i connect the 1841 router with the same config, directly to the 1812 trunk interface, fa2,

everything works!

I have no clue whatsoever right now, i hope someone can help me.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 07/29/2008 - 11:36

Hello Frederik,

when using 802.1Q trunks a possible problem is a mismatch in the native vlan

check the C2960 ports with

sh interface fas0/4 switchport

sh interface fas0/8 switchport

verify encapsulation, native vlan, list of vlans permitted and in forwarding state

both vlan 2 and vlan 3 must be permitted on both trunks

on the router you can use debug vlan packets

+ term monitor

Hope to help

Giuseppe

frkainvid Tue, 07/29/2008 - 12:17

Hi,

Thanks for your reply. The trunk port configuration on both the router and switch are as you can se in my first message simple, and exactly alike. The trunk works, but not for accessports on the switch. "sh ip int brie" shows up/up for vlan 2 for example.

//F

Giuseppe Larosa Tue, 07/29/2008 - 12:47

Hello Frederick

for access-ports

switchport mode access

switchport access vlan 2

the default is 1

Hope to help

Giuseppe

Actions

This Discussion