OSPF Tables not being inserted in routing tables

Unanswered Question

I am trying to get a 7507 and a 3550 to talk via ospf. The first router is 10.91.0.1 and the switch on vlan 1 is 10.91.0.100. The 3550 will learn all the routes and install them but the 7500 will see any routes from the 3550. The sessions are up:

7505:

router ospf XXXXX

router-id 10.91.0.1

log-adjacency-changes

area 1 authentication

redistribute static subnets

network 10.91.0.0 0.0.255.255 area 1

network 64.XXX.XXX.0 0.0.0.255 area 0

network 64.XXX.XXX.0 0.0.3.255 area 1

default-information originate

interface FastEthernet5/1/0 config

ip ospf authentication message-digest

ip ospf authentication-key 7 XXXXXXX

ip ospf cost 1

Neighbor ID Pri State Dead Time Address Interface

10.91.0.100 1 FULL/BDR 00:00:33 10.91.0.100 FastEthernet5/

1/0

and the databases are there on the 7505 7505#sho ip ospf data

OSPF Router with ID (10.91.0.1) (Process ID XXXXX)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count

10.91.0.1 10.91.0.1 1294 0x80000001 0x0075D0 1

but no ospf routes get installed

the routing tables on the 7507

the 3550:

3550#sho ip ospf

Routing Process "ospf XXXXX" with ID 10.91.0.100

Start time: 5w1d, Time elapsed: 8w4d

Supports only single TOS(TOS0) routes

Supports opaque LSA

Supports Link-local Signaling (LLS)

Supports area transit capability

It is an autonomous system boundary router

Redistributing External Routes from,

static, includes subnets in redistribution

Router is not originating router-LSAs with maximum metric

Sum 0x176A114

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Number of areas transit capable is 0

External flood list length 0

IETF NSF helper support enabled

Cisco NSF helper support enabled

No auto cost

Area 1

Number of interfaces in this area is 2

Area has simple password authentication

SPF algorithm last executed 00:26:59.336 ago

SPF algorithm executed 2 times

Area ranges are

Number of LSA 6. Checksum Sum 0x06E6C0

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

3550# sho ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

10.91.12.4 1 FULL/DR 00:00:33 10.91.12.4 FastEthernet0/

22

10.91.0.1 1 FULL/DR 00:00:36 10.91.0.1 Vlan1

router ospf XXXXX

router-id 10.91.0.100

log-adjacency-changes

no auto-cost

area 1 authentication

redistribute static subnets

network 10.91.0.0 0.0.255.255 area 1

network 64.XXX.XXX.0 0.0.3.255 area 1

interface Vlan1

ip address 10.91.0.100 255.255.255.0

ip ospf authentication message-digest

ip ospf authentication-key 7 XXXXXXX

ip ospf cost 1

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sdoremus33 Tue, 07/29/2008 - 17:33

Add default-information originate to 3550rtr

also check the ip ospf cost at both routers. They are running in a broadcast multi-access correct and if the case this mode requires the election of a DR in the network set by the ip ospf cost.

cjsattler Wed, 07/30/2008 - 16:27

Ok, i tried inserting default-information originate on the 3550 and changed the cost on the 7507 to be 1 and the 3550 to be 10 and it still will not insert the routes.

if i do a clear ip route * , it will load the routes for a second, then they will disappear after 10 seconds.

7505#sho ip route ospf

64.0.0.0/8 is variably subnetted, 187 subnets, 11 masks

O E2 64.XXX.XXX.0/28 [110/20] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

O 64.XXX.XXX.0/27 [110/111] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

O E2 64.XXX.X.0/24 [110/20] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

O E2 64.XXX.XXX.48/28 [110/20] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks

O 10.91.12.0/24 [110/101] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

my configs for the ospf are now:

7505:

router ospf XXXXX

router-id 10.91.0.1

log-adjacency-changes

no auto-cost

area 1 authentication

redistribute static subnets

network 10.91.0.0 0.0.255.255 area 1

network 64.XXX.XXX.0 0.0.0.255 area 0

network 64.XXX.XXX.0 0.0.3.255 area 1

default-information originate

3550:

router ospf XXXXX

router-id 10.91.0.100

log-adjacency-changes

no auto-cost

area 1 authentication

redistribute static subnets

network 10.91.0.0 0.0.255.255 area 1

network 64.XXX.XXX.0 0.0.3.255 area 1

7505#sho ip ospf

Routing Process "ospf XXXXX" with ID 10.91.0.1

Start time: 00:02:18.064, Time elapsed: 7w6d

Supports only single TOS(TOS0) routes

Supports opaque LSA

Supports Link-local Signaling (LLS)

Supports area transit capability

It is an area border and autonomous system boundary router

Redistributing External Routes from,

static

Router is not originating router-LSAs with maximum metric

Initial SPF schedule delay 5000 msecs

Minimum hold time between two consecutive SPFs 10000 msecs

Maximum wait time between two consecutive SPFs 10000 msecs

Incremental-SPF disabled

Minimum LSA interval 5 secs

Minimum LSA arrival 1000 msecs

LSA group pacing timer 240 secs

Interface flood pacing timer 33 msecs

Retransmission pacing timer 66 msecs

Number of external LSA 15. Checksum Sum 0x248708

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 2. 2 normal 0 stub 0 nssa

Number of areas transit capable is 0

External flood list length 0

Area BACKBONE(0) (Inactive)

Number of interfaces in this area is 15

Area has simple password authentication

SPF algorithm last executed 00:02:17.772 ago

SPF algorithm executed 5 times

Area ranges are

Number of LSA 9. Checksum Sum 0x057969

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

Area 1

Number of interfaces in this area is 1

Area has simple password authentication

SPF algorithm last executed 00:02:27.856 ago

SPF algorithm executed 5 times

Area ranges are

Number of LSA 6. Checksum Sum 0x226CA7

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

Kwamet Thu, 07/31/2008 - 07:06

I need show ip ospf database database-summary output on both

But remember 7505 has the addr so why should it put it its table check the addr properly

Richard Burts Thu, 07/31/2008 - 10:03

There are a couple of things in this thread that I find puzzling. The thread was started by dan obrien of wells gardner, but is continued by Charles Sattler of

LasVegas.Net. Is this really the same issue on the same equipment?

Also this post shows a number of routes that are learned from the 3550:

7505#sho ip route ospf

64.0.0.0/8 is variably subnetted, 187 subnets, 11 masks

O E2 64.XXX.XXX.0/28 [110/20] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

O 64.XXX.XXX.0/27 [110/111] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

O E2 64.XXX.X.0/24 [110/20] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

O E2 64.XXX.XXX.48/28 [110/20] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks

O 10.91.12.0/24 [110/101] via 10.91.0.100, 00:00:01, FastEthernet5/1/0

Is this an example of the routes which appear immediately after clear ip route or is it something else?

And if it is an example of the routes which appear immediately after clear ip route, do they really disappear from the routing table, or are they replaced by other routes?

If we could clarify these things we might be closer to a solution.

HTH

Rick

cjsattler Thu, 07/31/2008 - 15:38

Sorry, i didn't realize i was already logged in as someone else when i posted this, but it is the same person.

The problem was i had a static route for 10.91.12.0 which the ancillary routes that go there would not propagate across. Once that was deleted all the routes showed up

thanks

Actions

This Discussion