open udp port on Wireless Network

Unanswered Question
Jul 30th, 2008
User Badges:

I have a WLC2106 with 6 APs model 1240AG. An application uses port 11050 UDP for license management. The client send a broadcast on this port looking by the server, because this information is NOT passing through, the connection can't be established. With the original network (3com), there is no any problem but with Cisco network, this particular port appears to be closed. How can I confirm the AP is blocking this port? How can I open it? I tried with an ACL but the problem was not fixed.


thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ericgarnel Wed, 07/30/2008 - 07:55
User Badges:
  • Gold, 750 points or more

What level 3 changes have occurred along with the installation of the cisco network? The wireless will pass along any layer 3 information from the wired infrastructure. Where did you place the acl you mention?

descalante2007 Thu, 07/31/2008 - 13:15
User Badges:

The original network had a proxy server connected to the DSL modem. The proxy had been removed and now an Cisco2851 running CCME is used, the problem didn't happen whit the proxy replacement. It appears when we replace the APs. Actually when we test using the 3Com APs, we use the same network and configuration. I mean we may have the Cisco AP and 3com AP turned on at the same time, but propagating different SSID. When the user connects to 3com SSID, it can access the application. If we change in the PC to connect to cisco SSID, everithing works fine but this application.

I tried to define an ACL in the controller allowing to pass any traffic through port 11050. I applied the ACL to the dynamic interface used for data. Also I tried with the ACL associated to the WLAN and even both.

ericgarnel Fri, 08/01/2008 - 08:34
User Badges:
  • Gold, 750 points or more

Are there other apps on the same same subnet that you can try accessing from the cisco APs?

descalante2007 Fri, 08/01/2008 - 08:52
User Badges:

Actually it is the only application with problems. Users can access Internet, the local Windows domain, everything I know the users have is working.

As a workaround, the PCs running this application are connected through the wired network, but I need to find a solution because the users should have mobility.

descalante2007 Wed, 08/27/2008 - 10:48
User Badges:

Recently I did a new test with an autonomous AP1131, the application worked fine.

During my test, I issue "debug ip udp" in the router. When I have the 1131 and I saw the broadcast coming from the client PC. Obviously I can't see the answer because it is not passing through the router. When I have the 1242 LAP and the controller, I can't see the broadcast arriving to the router. So, this test should confirm the LAP or the WLC are dropping the UDP broadcast.

ericgarnel Wed, 08/27/2008 - 11:09
User Badges:
  • Gold, 750 points or more

Under the controller properties, do you have "Broadcast Forwarding" enabled?

descalante2007 Thu, 08/28/2008 - 08:26
User Badges:

I had verified controller options, the broadcast forwarding is enabled, but the approach is the same. I tried also with 802.3 bridging with the same results.

ericgarnel Thu, 08/28/2008 - 10:47
User Badges:
  • Gold, 750 points or more

Under the controller | WLANs | | Advanced


Do you have P2P blocking Action enabled or disabled?

descalante2007 Thu, 08/28/2008 - 13:24
User Badges:

Eric:

Thanks so much for your support. Finally I have the application working.

I found the problem was not with the UDP port alone, the problem was with all broadcast (your tips give me ligth).

Besides the "Broadcasting Forwarding" option I changed the "Ethernet Multicast Mode" to Multicast.

The key was this paragraph in the release notes:


Re-enable Broadcast after Upgrading to Release 4.0.206.0


In software releases 4.0.179.0 and earlier, broadcast and multicast forwarding were both controlled with a single global flag that enabled multicast. Beginning with software release 4.0.206.0, these functions were broken into separate configuration flags: one that controls broadcast and one that controls non-broadcast multicast. If you have multicast enabled in software releases 4.0.179.0 and earlier, the broadcast flag is left disabled after upgrading to software release 4.0.206.0. As a result, some applications that rely on broadcast do not work after the upgrade.

After you upgrade to software release 4.0.206.0, use this CLI command to re-enable broadcast:


config network broadcast enable


When re-enabled, broadcast uses the multicast mode configured on the controller.



To be honest I am not very clear how the multicast mode is related with the problem, but now I can see all the broadcast messages passing through wireless network.


Thanks a lot

Daniel Escalante.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode