moc - lcs configuration

Unanswered Question
Jul 30th, 2008

Can someone provide me the syntax for configuring the URI's in the LCS and MOC client?

We see invite msg in the presence sip-proxy traces but the moc can not control the phone. Also the moc has a exclaimation point icon saying the moc is not set up correctly for phone communication.

I've seen the CIsco doc of screenshots for the LCS, but it is still confusing.

thanks

Rob

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Wed, 07/30/2008 - 14:47

First off, you need to have matching login names on both sides for it work.

the uri has to match the extension of the phone you are trying to control.

A good test you would be to first try and get CUPC working with Remote Call Control. If it works, the move on to MOC to control the phone.

In CUPS Troubleshooter, is everything green or do you have errors?

Check my other post here for the "all" settings.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=Unified%20Communications%20Applications&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40^1%40%40.2cc0609b/7#selected_message

Also check to make sure your DNS is working correctly on CUPS so it can resolve host names, etc.

rvincent Wed, 07/30/2008 - 15:55

ok.

names are the same. I saw your post regarding that. MOC users login name is same as ccm user name.

how is the uri written? Is it tel:xxxx or does it have more?

CUPS troubleshooter is green all the way.

Good idea about trying the CUPS client.

thanks

Rob

Tommer Catlin Wed, 07/30/2008 - 18:40

The best way to figure out Presence and MOC problems is to open up the Real Time Monitoring Tool and check out the real time log for SIP Proxy. You will see every invite, and communication between MOC and CUPS. This is where I would find the invites and who was talking what. I eventually would find some problem in the SIP invites because of some some programming issue. IE, [email protected] did not match the URI CUPS was expecting [email protected] etc (or something like that)

I have not done a MOC in a little while, but if you search the forums for MOC and LCS you will find plenty of information. I can try and dig up some notes. Cisco's snapshots are wrong. So unless you know how to log at log files and understand OCS and how it works, you will be battling forever.

On the OCS side, can you resolve the CUPS server name? You may want to change it all to IP address. so the tel would be [email protected] (IP address of CUPS) Then on the CUPS server, change all the server names to IP address and see if it works.

But try and get CUPC to work, then work on MOC after that. At least you know with CUPC that CTI and remote call control is working. Then you can simply add in MOC enablement and get OCS to work. MOC will simply send the sip invite messages to CUPS, then pass to CUCM CTIs for call control.

CUPS will send Presence information it gets from CUCM to MOC. MOC client will then get updates with the pretty colored icons, etc.

I know for sure that MOC and CUCM users (if not LDAP enabled) have to match, or it will not work. They are really picky on this. I found in my RTMT logs the SIP invite from MOC to CUPS things like:

12/04/2007 18:47:41.842 ESP|PID(27354) mod_sip_ctigw.c(1518) UserId Nexus.Test does not have a MOC license or not authorized

Nexus.Test was my MOC user, but on CUCM my user name was test1 associated to a device/line, etc. So once i fixed that, everything started to work.

It's a pain, but keep reading the forums, you will find the answer or keep asking questions.. see what we can do for you!

rvincent Thu, 07/31/2008 - 04:37

thanks for taking the time to write...

i think we noticed is the moc client says its not configured for phone communication, or something like that. Even has an error icon in its task bar.

So my thought was , the MOC is not configured correctly. But I do see invite msg in the presence trace.

Rob

Tommer Catlin Thu, 07/31/2008 - 08:08

ON the MOC client, you have to edit the Registry on that machine to allow the use of the phone system or create a Group Policy in AD to allow the use of the phone system. There is a toggle in the registry (locally on the client PC) to turn this on. If it's grayed out, that is your problem.

rvincent Thu, 07/31/2008 - 08:14

it was grayed out but we cleared that issue.

now we have an icon on bottom of client with a caution sign.

when you put mouse over it it says "communicator is not properly configured to make phone calls"

Rob

Tommer Catlin Thu, 07/31/2008 - 08:18

Ok, so now you need to review your server settings for the MOC client. wish I had an OCS server here to help you with, but I do not.

Here are some more links.

i,

there is a new guide for your scenario: http://www.cisco.com/application/pdf/en/us/guest/products/ps7036/c1237/ccmigration_09186a008089b71d.pdf

Did you check with the troubleshooter tool in CUPS?

For the new OCS there also exists a guide: http://www.cisco.com/application/pdf/en/us/guest/products/ps7240/c1237/ccmigration_09186a00808aea28.pdf

hopefully they are valid.

Check out this string as well.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=Unified%20Communications%20Applications&topicID=.ee835d2&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40^1%40%40.1ddda965/17#selected_message

If you are using TLS, change it for now.

rvincent Fri, 08/01/2008 - 04:40

thanks again for all your info.

we were able to get it working by doing a number of things, so I'm not sure yet if one or all of them were needed.

first we removed tls and went to tcp. tac said there is a bug with trying to use tls when lcs servers are load balanced - CSCsg13548.

second, in lcs, the authorized host was added with IP address - it had been in with fqdn.

third, in ccm, the moc user's mail id was changed to [email protected]

Rob

Tommer Catlin Fri, 08/01/2008 - 07:54

Sounds right. TLS for sure does not work.

It could be IP address, IF you use IP address on the CUPS side. If you use fqdn, then it has to be hostname. I think on MOC if I remember, you can only use fqdn. (then on your network, you have to have a DNS entry for CUPS server.

Yup, the mailid. You can see that in the log files in the SIP proxy log.

Glad to hear it works!

rvincent Fri, 08/01/2008 - 10:04

just to add to it....

I removed the mail id entry in the ccm user setting and it still works, so i don't think that was necessary.

Rob

Actions

This Discussion