packet loss on ME3400

Unanswered Question
Jul 31st, 2008

I've been testing ME3400 switches at the bench, with results that concern me. I'm running very simple QoS, and when I put 45Mbps of UDP traffic through to a 100Mbps port, I get packet drops. The traffic is not very bursty, but I see drops whether the queue-limit is set low or high.

Has anyone else seen this sort of behavior? Is there a setting I've missed? IOS versions to avoid? Packet sizes which cause trouble (I test with 1400 byte packets to keep packet rates low)?

Any advice appreciated. I have a TAC case on this, but they have not been able to say much.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
DavidSarvai Wed, 08/06/2008 - 18:20

Hey Evan,

We are using the ME3400s now, and did run into some problems with QOS, as well as routing throughput on the smaller ME3400s running the enhanced Metro IOS.

We were in the lab using JPerf to generate traffic through the 3400s and found the smaller chassis maxed out below 40MB.

Drop me a line for more details.

I'm in NH.

Atif Siddiqui Wed, 06/17/2009 - 19:52

i dont see any interface drops, while having performance issues? should we implement this class-maps?

Atif Siddiqui Wed, 06/17/2009 - 19:50

We are expereincing similar issues in our network; using ME switched to connec remote sites via TLS, having performance issues, asymmetric throughput using IPerf? on a 100 MB link we see 90 MB 1 directions and 55MB the other.

did you get any answer to this problem? we are using this code 12.2(35)SE1; cisco ME-3400G-12CS-D

Atif Siddiqui Thu, 06/18/2009 - 16:26

I have got an answer today;

if you are going 1G to 100 MB on an ME 3400 swtich with an older code like 12.2(35)SE1; it will drop your performance to half. in other direction it won't as it is going to 100 MB to 1G...

new code 12.2(50)SE1 fixes it, i don't have the bug id as there are none, but will ask Cisco to file it.

evan.r.moore Fri, 06/19/2009 - 05:30

Good job tracking that down, and thanks.

I've love to know the bug id when you get it.


Atif Siddiqui Tue, 06/30/2009 - 10:28

Cisco has listed a cavet here:

Increased default value of buffer (from 48 to 160 packets - see Cisco

reference ID CSCsm80634)

which was the problem we were having. the queue size is increased in the new code.


This Discussion