RME 4.0.6 - Problem to update device libraries

Unanswered Question
Aug 1st, 2008

After the update from RME 4.0.5 -> 4.0.6 I wanted to update the device libaries via CS->Softwarecenter->Device update too. But I have a problem to update libswim from v1.8.1 -> v1.8.5.

Accoring the cisco documentation the only dependency is the libcommon v1.3.4. That is already installed. Also mdf v1.23 is installed. When I try the update comes this error message:

***** WARNING : LibSwim(1.8.5):Consistency check failed for base package SharedSwimOpticalSwitch ******

The installed version for SharedSwimOpticalSwitch is v1.1 and I can't find a newer version in CCO.

Thanks + Best regards


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Joe Clarke Fri, 08/01/2008 - 09:08

This indicates a bad installation of RME 4.0.6. I'm betting this is Windows. In order to ensure the best possible installation on Windows, you will need to set the per-user and global TEMP and TMP environment variables to something short like C:\WINDOWS\TEMP. You will also need to disable anti-virus scanning, and perform the installation as a local Administrator on the server's console.

At this point, you will need to uninstall and reinstall RME. This will be tricky, so you should open a TAC service request to have them help you through it.

The latest version of SharedSwimOpticalSwitch for RME 4.0.6 is 1.5.

hleschin Mon, 08/04/2008 - 00:03

Thanks for the information. You are right, it's a windows installation.

I have opened a case at CCO just now.

hleschin Mon, 09/01/2008 - 05:13

The result of the TAC-case was to reinstall RME4.0.6. An uninstallation of RME was fortunately not necessary.

The reinstallation solved the problem. The tac-engineer wrote that this problem happens occasionally, but only for the upgrade from RME4.0.5->4.0.6. The reason for that is currently unknown.


This Discussion