DHCP Server config on 2960G, 3560G and 3550 switches

Unanswered Question
Aug 2nd, 2008


Im using 2 x 3750G switches as callapsed core/distribution switches. I have 6 Vlans (1, 10,20,30,40,50) that will be assigned per switch block.

Switch block 1

This will have 5 switches in the block connected at the top switch via fibre trunk to core_1 and at the bottom switch via fibre trunk to core_2. Each switch is then daisy chained, via copper, to one and other and all switches in the stack have vlan 10 assigned to there ports. Vlan 1 also has access as it is the management vlan and all servers are configured on this vlan.

All the other switch blocks are connected the same as above but have a different Vlans configured and some have less switches in the stack.

I have a selection of switches mainly 6+ x 3560G's, but also 3550G, 3550 and 5 x 2960G's.

I'm looking at configuring a DHCP server on the top switch on each switch block/stack, to assign IP address to clients on the assigned vlan eg Vlan 10 - network.

I have been trying to configure DHCP on a 2960G Lanbase switch but cannot get it to assign an ip to a laptop I plug in to it.

I have reset the config now but was trying:

ip dhcp pool Vlan10


default-router (ip of vlan 1 on core_1)

option 150 ip (not sure why? read a sample config)

dns-server ***.***.***.****

(again do not have dns-server configured and connected to the network, just 1 x laptop, 2x cores and 2 x 2960G's)

I assigned an IP address pool and created excluded-addresses, but still I have problems!! :0(

Can someone please help me with the config as I'm struggling? , also if the configuration would be better on one of the other model of switches I have eg. 3560G etc then please give your opinion?

Many thanks


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Marwan ALshawi Sat, 08/02/2008 - 07:27


u have to creat the required VLAN(s)

then for each VLAN u have to Creat a DHCP config the relate to that vlan and havs the right ip subnet

lets say u have vlan 10

make the vlan on ur access layer switch

with command

vlan 10 [enter]

name vlan_10

then assign this vlan to the required ports

and make sure the switch port no shutdown anslo the is Important thing which is the spanning tree PORTFAST this otion if u dont put it on access port for client need DHCP u gonna loss the DHCP

for example

interface range fa0/1 - 24

switchport mode access

switchport access vlan 10

spanning-tree portfast

no shut

these ports ready to connect the PCs

now next step for distribution layer and DHCP

make the connection between the access switches and the Dist switches trunk to pass VLAN tags

then on the Dist switches creat the same vlans numbers

and creat for each vlan a switched virtual interface SVI which will be the defaul gateway for client in the corspoding VLAN

example Dist switch

vlan 10

vlan name vlan_10

interface vlan 10

ip address

no shut will be the default gateway for vlan 10 users

then go to configure the dhcp on the switch

note: if u have the dhcp on other router, switch or server u have to add th ip hlper command on the SVI interface poiting to that dhcp server

in our example the Dist switch will be the dhcp so we dont need that command

ip dhcp pool vlan10




about option 150 this option used when u have IP telphoney and voice vlan to point to the TFTP server

if u dont have u dont need it

and repeat the same config for each vlan but with deffrent ip address

for example dhcp for vlan 20

shoud like

ip dhcp pool vlan20


default-router 20..1.1.1

and so on

dont for get the SVI

and the access port config with portfast

being enable

also check the dhcp service if enabled or not(by default yes)

this link also helpful


good luck

please, Rate if helpful


This Discussion