Intervlan on switch

Unanswered Question

Can I do the routing on the cisco switch 3650?

May I know how to do the intervlan on cisco switch 3650 so that I can let the user on vlan2 (cisco switch 2950) to use the printer on vlan3 (cisco switch 2950)? Please provide me the example like coding and everything. Your help is much appreciated. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marwan ALshawi Mon, 08/04/2008 - 07:03

in 3650 switch

it is by default layer two switch

u have to enter ( ip routing command) two enable routing capabilities

once u entered that comman u can deal with the switch as router when u do routing

and for VLAN routing the idea is first creat what is called virtual switch interface SVI

for each vlan

for example

vlan 10

if u wanna creat SVI for that vlan

u have:

interface vlan 10

ip address x.x.x.x y.y.y.y

no shut

after u made the ip address and subnet

it will considered as directly connected interface

now if u have more than one vlan

with each it own SVI created

just do

show ip route

u gonna see all those SVI as directly connected in this case the switch will routed between them

now for communication between vlans

in ur case,

vlan 3 on 3650 and SVI for vlan 3

also the same for vlan two

on each switch of 2950

creat vlan 2 and vlan 3

but do not creat any SVI there

now make the connection between 2950 and 3650 as trunk to pas vlans traffic

then lets say the fowloing u have don on 3650

vlan 2

interface vlan 2

ip address 192.168.1.1 255.255.255.0

no shut

vlan 3

interface vlan 3

ip address 172.16.1.1 255.255.255.0

no shut

now u should have created vlan 2 on 2950

lets say ur client connected to port 1

interface fa0/1

switchport mode access

switchport access vlan 2

no shut

if u use dhcp put

spanning-tree porfast

now on ur client the ip address shou be

in 192.168.1.0/24 rabge

like 192.168.1.2

and the default gateway will be the vlan 2 SVI on 3650 switch

which is 192.168.1.1

and subnet mask same as the SVI 255.255.255.0

and the same idea for the vlan 3 but with is IPs

the link provided to u above by Massimiliano

very good

so i wish u good luck

if u need any more details post it here

please, if helpful Rate

Marwan ALshawi Tue, 08/05/2008 - 05:40

i attached full config and should be fine to make communication between ur pc in vlan 2 and printer in vlan 3

good luck

please, rate if helpful

Attachment: 
Marwan ALshawi Wed, 08/06/2008 - 06:38

ok

this is a dhcp pool

dynamic host configuration protocol

instead of puting ip address and default gateway on each computer in vlan2 here in ur case

u just pug the pc and make the ip assignment in the computer to automatic

then to see the pc if it has got the ip

go to start>run then tryp cmd

then tryp ipconfig then hit enter

u should see the ip address in the range of 192.168.1.0

and exculusde mean that this dhcp will start from 192.168.1.2 and dose not give 192.168.1.1 as ip address to others

i have don this becase the vlan 2 ip address has taken this address and if any computer take it will make problem

like when u there is two people have the same telephn number within the same company wont work

about spaning treeportfast

this related to technology in switched network that prevent loops

but it has timers that delay the port and make problems when configured with dhcp

so this option only put it to access ports when u use dhcp

i hot i was helpful

and please, if helpful rate any post u find it helpful

Actions

This Discussion