EIGRP Interface-passive command

Unanswered Question

Hi All,


Just want to clarify something regarding EIGRP interface-passive command. I made serial0/0 passive in eigrp, but i can still routes passing to the serial link. Do i need to make the serial sub-interface passive rather than the serial interface to stop inbound and outbound advertisements?


Here are my current configs.


interface Serial0/0

description Serial0/0

bandwidth 64

no ip address

no ip redirects

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

no fair-queue

service-module t1 timeslots 1

frame-relay lmi-type ansi

!

interface Serial0/0.300 point-to-point

description PVC TO Remote

bandwidth 32

ip address 10.209.22.153 255.255.255.252

ip accounting output-packets

ip nat outside

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 300

frame-relay payload-compression packet-by-packet

!

interface Serial0/0.400 point-to-point

description PVC TO Remote

bandwidth 32

ip address 10.203.18.125 255.255.255.252

ip accounting output-packets

ip nat outside

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 400

frame-relay payload-compression packet-by-packet


router eigrp 500

passive-interface Serial0/0

network 10.0.0.0

network 172.25.0.0

distribute-list 45 out Serial0/0.300

distribute-list 45 out Serial0/0.400

no auto-summary

no eigrp log-neighbor-changes


RTA#sho ip eigrp neighbors

IP-EIGRP neighbors for process 500

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

2 10.209.22.154 Se0/0.300 14 18:28:09 66 5000 0 19333965

1 10.203.18.126 Se0/0.400 11 18:28:30 50 4560 0 27775706

0 172.25.209.154 Tu0 14 7w2d 10 5000 0 232438

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
royalblues Tue, 08/05/2008 - 08:36

Yes,


The passive interface command would be required under the sub-interface.It need to reference the interface carrying the IP address


However it would prevent the formation of neighbor adjacency. If you just want to restrict routing updates, the distribute-list you configured is the correct way



Narayan



Actions

This Discussion