Nortel SIP Phone on CUCM

Unanswered Question
Aug 5th, 2008


I have recently converted a Nortel shop to Cisco CUCM 6.1(2), and have the need to register several Nortel 1140E's to CallManager.

I have searched here and googled, and am not coming up with anything. I have also added the phone's MAC as an advanced SIP endpoint, manually changed the tftp server, and it doesn't come up. I believe that it already has a SIP image.

Any thoughts?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jeff.heckart Fri, 08/08/2008 - 11:11

So, after a little working with this, I found that they are UNISTIM, not SIP.

They must first be upgraded to a newer release of UNISTIM, then upgraded to SIP.

My biggest problem now is getting a hold of the firmware. I'll post back how this ends up.

jeff.heckart Wed, 08/13/2008 - 10:10

I finally got the firmware and was able to upgrade to SIP. I also authenticated the phone to CUCM, and am able to make calls.

bannouraw Sun, 02/22/2009 - 23:12

we have the same issue, could you please let me know how to get the SIP firmware.

jeff.heckart Mon, 02/23/2009 - 03:24

I had to get it from a Nortel vendor. I tried creating an account with Nortel, but didn't have anything associated with my Nortel account.

lstoked Thu, 10/22/2009 - 10:16

Jeff you seem to be about the only person that was able to get a Nortel phone to register to CM using SIP. Do you have any specifics to what you did to get this to work? I've tried it on a 6.1(3) and a 7.1(2) system and I can't get it to register. The phone is running SIP already. I see SIP messages going to CM in RTM but the phone will not register. I've tried creating the username as the extension number per some post but still no luck.


For anyone looking for the Nortel SIP and/or Unistim firmware...  Both ARE available @ and are available WITHOUT needing a registered account or even logging in as guest.  In my case, the Unistim firmware hadn't been updated on the Nortel 1140e in several years. This seems to be typical in the legacy telephone world where managed service seems to prevail & the purveyers of such subscribe to the "if it ain't broke don't touch it and save us money" school of thought.

Due to this, I found it neccessary to upgrade to a current version of Unistim FIRST before I was able to do the SIP firmware load.  Both Unistim and Sip firmware updates are outlined in the documentation freely available on the Nortel site.  In addition, both can be accomplished with nothing more than a stand alone TFTP server -no Nortel server required..

Hope this helps.


rayangandhi Tue, 01/04/2011 - 09:56

I have been able to successfully connect a Nortel 1140e SIP(Ver. 3.2) phone to callmanager 7.1.3.  Features on the phone work as I expect but, the issue I keep running into is that the call drops after about 2 mins and the phone goes through a login scrit.  While it does this, it looks like the phone is attempting to obtain a token.  Could this be something with a SIP timer in call manager?


Richard Hermann Wed, 08/10/2011 - 06:34

I am really struggling to get an 1140e SIP (ver. 4.0) configured on CUCM 8.5.

You guys have some details of the technical aspects?  I am familiar with using the .cfg files with a TFTP server (I have one setup separate from CUCM's). I have created a basic and advanced SIP phone on CUCM with a digest user (using LDAP integration) and keep getting a server: 404 error on the phone.  I have tried other variations of the domain name and server info (pub then the subs).  I have also tried w/o digest authentication.

Thanks in advance,


tedbienapfl Thu, 10/13/2011 - 13:35

Richard - did you get anywhere with this?  We are struggling with the same 404 error you talk about...

Richard Hermann Thu, 10/13/2011 - 13:59

Yes!  The name of the user must be the extension you want the phone to be. 

So, if you are not LDAP integrated, its easy.  Just create a user with a user ID that is the extension number and set the digest credentials (something easy works well, 0000).

If you are LDAP integrated, then you have to create a user in your AD with the user ID that is the extension number.  Don't worry about setting a password or anything in AD, you won't need it.  Once that's done, find the user in your Call Manager and set its digest credentials.  If you don't find the user right away, just go and run a sync in your LDAP settings and give it a couple of minutes.

And on the phone, set the domain as the publisher IP address and the S1 as the first subscriber in the Call Manager group the phone will be associated with (maybe the same, mine was different).  Then login with the extension number (user ID) and password (digest credential).

Hope that helps!

tedbienapfl Thu, 10/13/2011 - 14:17

So - nortel config file wise...

The CUCM Side and AD Piece is good to go.







DEF_USER1 user1






Richard Hermann Thu, 10/13/2011 - 14:33

I got most of my guidance at this guy's site @

Need two files. 

First one and name of the file has to be 1140eSIP.cfg



VERSION SIP1140e04.00.04.00.bin

FILENAME SIP1140e04.00.04.00.bin






VERSION 000002

FILENAME users.dat



VERSION 000002

FILENAME dialplan.txt

(you'll get an error about that dialplan stuff when the phone loads up, but don't worry about it)

Second one and name: users.dat

DNS_DOMAIN {your domain}

SIP_DOMAIN1 {Publisher IP}

SERVER_IP1_1 {first subscriber IP} (maybe also your publisher)



DEF_USER1 user


VMAIL 5000


DEF_LANG English



ADMIN_PASSWORD 865625 (this spells UNLOCK, but not sure if you need one though)


# Settings to disable extended license










# Enable SSH


SSHID admin

SSHPWD admin

tedbienapfl Fri, 10/14/2011 - 06:39

ok - all those settings are identical to what you have above, but...

I still get the following error:

Failed to login user, server error: 404

Can't find the URI on CUCM

We are running

CUCM System version:

Any thoughts?

Richard Hermann Fri, 10/14/2011 - 07:13

Hmm, are you using DNS names rather than IP addresses for your SIP_DOMAIN1 and SERVER_IP1_1?

What are you Using for your DNS_DOMAIN?  Ours is a little different than our web doamin.  Check yours by looking up your computer name under system properties on a windows machine. 

Any access lists' on the voice vlan?

tedbienapfl Fri, 10/14/2011 - 07:17




no ACL's of any sort

very simple network...

Richard Hermann Fri, 10/14/2011 - 07:27

Did you create a new Third-party SIP Device Basic - Standard SIP Non-Secure Profile with digest credentials required?

You will need to select it in the phone's device security profile under protocol specific information.

I created one for basic and advanced.  You can use either, does not matter, but the advanced uses more DLUs.

tedbienapfl Fri, 10/14/2011 - 07:43

screen shots helped - we are trying these settings now and ill get back to you

Richard Hermann Fri, 10/14/2011 - 07:55

Awesome!!  Glad I could help!!  The Nortel folks aren't so great with documentation, so I know how it goes!!

tedbienapfl Fri, 10/14/2011 - 08:22

One last issue...

Every minute the Screen on the nortel flashes and say "Logging in User".  Any way to stop this?

Richard Hermann Fri, 10/14/2011 - 08:36

Probably check the config files (1140eSIP.cfg and users.dat) for something.  I've seen something when you do login, that it can be a timed login.

You can find the SIP admin guide for the 1100 series phones @

It will explain all the stuff in those files.

Updated to work..

tedbienapfl Fri, 10/14/2011 - 09:53

What im seeing is that the calls are just plain dropped and the phone (no timed login) just basically restarts...

im gonna hang it up for the day if I can't get this soon...

Richard Hermann Fri, 10/14/2011 - 11:01

So the phone restarts every time you make a call to it??  I would check for a codec mismatch..

tedbienapfl Fri, 10/14/2011 - 11:25

No - we have Dial Tone and 711 is the codec.  Just every 30 seconds (we timed it) the screen flashes and it is like the phone "resets".  No matter what you are doing.  Service panels, home screen, in a call, etc...

we are looking for any values in CUCM that may be what is causing this.

Richard Hermann Fri, 10/14/2011 - 11:34

Check your enterprise parameters clusterwide domain configuration.

With that, I also created host records in DNS for pub and all my subs.  So the cluster fully qualified domain will be the one you set for you pub.

tedbienapfl Fri, 10/14/2011 - 11:41

same thing after adding that above...  I am going to maybe reach out to TAC after I do a snif on the link as this just seems very weird.

Thanks Again for all the help - it is appreciated.

tedbienapfl Tue, 10/18/2011 - 07:14

Ok - got over the main struggle.  THe problem we have now is that once a call is established, any keys that are hit during a call (think voicemail password, etc..) do not register at all.  They are totally ignored.  Other Cisco phones do work as expected in this type of scenario.

Did you have to make any settings changes in CUCM or on the Phone setup to allow for the tones to be recognized?  Once I have this, I think we are good to go...

Thanks All

Richard Hermann Tue, 10/18/2011 - 11:12

Your DTMF tones aren't coming through.  Check your protocol specific info under the phone settings in Call Manager.

philippe.cousineau Wed, 02/22/2012 - 11:43

Hi guys,

I feel really dummy on this one... I have configure my tftp server,

firmware SIP1120e04.00.04.00 is on it with the .cfg file

But, it doesnt even contact the tftp server.

My dhcp server have the option 66 and 150 that point to the tftp server... but nothing happend.

the firmware right now is : 2version micropr.:0624c60

Richard Hermann Thu, 02/23/2012 - 12:48

Are you using a separate TFTP server for the Nortel phones?  The Nortel phones don't use option 150 (i believe), the Cisco phones do.  As for option 66, not sure either, but option 128 they do.  Try hard coding the TFTP server into the phone first. It will be the 'provisioning' server option on the Nortel.  This way we can be sure that you are not having any connectivity issues between the phone and TFTP server.  For a TFTP server, I use Tftpd32.


This Discussion