Roaming clients

Unanswered Question
Aug 5th, 2008

I have a new WLC configured and 12 LWAPPs installed at my office. I have an ACS configured as well as IAS for aaa auth. I've noticed that many wireless laptops roam between 1 to 3 different LWAPPs. This is odd, especially because some devices are very close to AP's and get great signal streagth. Is this nature due to aggressive load balencing? Or do I have my 4402 misconfigured?

Any help for this Newbie is appreciated.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Scott Fella Tue, 08/05/2008 - 16:26

Aggressive load balancing can cause clients to attach to a further ap if it is congested. Client devices determine what ap to associate to. Not knowing how the ap's are laid out on the floor nor not knowing how the power and channel is configured, makes it a bit tough to figure it out. If your ap's are pretty close and you can get a good signal from multiple ap's in a give area, then try to disable data rates below 11mbps. Leave 11mbps set to mandatory. This will help prevent clients from staying associated to an ap if it has a signal less than 11mbps. However, if you have to support legacy clients, then you will need to have 1mbpx and 2.2mbps enabled. You can try to disable aggressive load balancing to see if that makes a difference or not.

dan474019 Wed, 08/06/2008 - 03:04

Thanks Fella5,

Yes the AP's are close enough to offer signal strength -30 to -35dbm. I failed to mention that I have aggressive load balencing "disabled". Also, I have "Global settings" enabled for all the LWAP's, so the WLC controls power and channel selection. Also, wireless customers are static (same location) when roaming occurs.


Thanks for the idea of disabling lower rates. I will investigate this as a solution.

dan474019 Thu, 08/07/2008 - 03:44

Results are that just disabling the lower data rates did not resolve my issue. I realize now that the "Timeout Session" coinsides with the deauthroization. I confirmed this by bumping the default from 1800 seconds to 3600.

Now trying to understand why the devices select a different LWAP during reauthorization has led me down the CCKM path. I've "Enabled" Aggressive load balancing on the WLC as if I read correctly the session timeout is not used with this enabled.

Not sure if I am going down the right path. Any comments?

Scott Fella Thu, 08/07/2008 - 19:14

You can always enable that feature and see if that helps your situation. Are all the devices have the same wireless card? Is the driver recent or very old? When a device boot up and associates to an AP, what is the signal that device is getting? How close are the ap's mounted?

dan474019 Fri, 08/08/2008 - 05:55

Yes, we are a Dell shop using both Intel Proset and MS wireless tools. The previous changes I made did not improve my environmet. Further research has led me to WPA2 and the Proactive Key Caching (PKC), a feature added to WPA2 that permits wireless clients to roam without full re-authentication. This may aliviate the roaming during re-association. I have reconfigure my wirless connection from WPA to WPA2, now lets see if roaming is reduced.

dennischolmes Mon, 08/11/2008 - 05:39

Also, on your clients, reduce or increase the roaming aggressive setting to roam more effectively. It is always better to allow the client device to determine when it should roam and allow the controller to speed that roam time up with features like PKC and CCKM.


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode