UC520 UPGRADE

Answered Question
Aug 5th, 2008
User Badges:

I just upgrade my uc500 to the cue version 3.2.1 using the US version. Everything is ok, but I having problems trying to upgrade to es-CO spanish version, when I issue the software install command with the cue-vm-es_CO-langpack.ise.3.2.1.prt1 file , I receive the following error:

Validating package signature ... done


ERROR: Invalid package. Please verify if this is a valid package file.

I just downloaded the file several times from the cisco page, I dont know what is the problem....

Thanks.

Correct Answer by Pari Thiagasundaram about 8 years 11 months ago

You are missing the package file.

To change the language you must have both files:

language_package.pkg

cue-vm-es_CO-langpack.ise.3.2.1.prt1


When specifying the package to CUE, you must specify the .pkg file


Please rate post if it helps.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Correct Answer
Pari Thiagasundaram Tue, 08/05/2008 - 12:32
User Badges:
  • Silver, 250 points or more

You are missing the package file.

To change the language you must have both files:

language_package.pkg

cue-vm-es_CO-langpack.ise.3.2.1.prt1


When specifying the package to CUE, you must specify the .pkg file


Please rate post if it helps.

Rafael Jimenez Tue, 08/05/2008 - 13:42
User Badges:

Sorry post after rate the post. But I still have problems....

I issue the following three commands:

software install upgrade url ftp://192.168.10.11/cue-vm-langpack.ise.3.2.1.pkg

software install clean url ftp://192.168.10.11/cue-vm-langpack.ise.3.2.1.pkg

software install add url ftp://192.168.10.11/cue-vm-langpack.ise.3.2.1.pkg

I receive the following error afeter each command:

AFTER TRY CLEAN

Error: The package contains only add-ons, which is not valid for clean-install



AFTER TRY ADD


Language add-ons found on the system (1):




Installed SKU Name (version)


------------------------------------------------------------------


* ENU CUE Voicemail US English (3.2.1.0)




Maximum allowed language add-ons (=1) already installed.


You can use "software uninstall" to remove add-ons.




AFTER TRY UPGRADE



The system will be brought to offline state for a brief period


and will be brought back to online state automatically


Calculating delta.... complete.


Running Script Processor for ui_upgrade


ui_upgrade scripts executed successfully.


Retrieving calculated file change sets:


- Installed file sets...complete.


- Target file change sets...complete.


Comparing changed source and target files...complete.


Calculating upgrade work order ... complete.


Creating uninstall change sets:


complete. No added files found.


- logging added components ... complete. No removed files found.


Clearing previous downgrade files ... complete.


Uninstall change set processing complete.


No work order generated for upgrade.


The system is back in online state



What I have to do?. helper installer?.

Thanks.

cogden Wed, 08/06/2008 - 17:20
User Badges:
  • Bronze, 100 points or more

Anyone got any ideas?


I am trying to add a French language add-on to CUE 3.2.1. I tried both CA French and FR French, but with the same result.


I have downloaded the file again and got the same error message when trying to add it.

Could it be that Cisco posted a corrupt language.pkg file?

I have done an MD5 check on the actual downloaded file and it DOES matchup to the one Cisco post, so the file is OK.

Here are the official instructions:

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/unity_exp/rel3_2/installation/guide_/nuinstall32.html

Here is where you get the .pkg CUE files from:

http://www.cisco.com/cgi-bin/tablebuild.pl/cue-321-nme


se-172-30-101-11# software install add url ftp://172.30.101.24/cue-vm-fr_CA-langpack.nme.3.2.1.prt1 username cuecue password cuecue

WARNING:: This command will install the necessary software to

WARNING:: complete an add-on install. It is recommended that a backup be done

WARNING:: before installing software.

Would you like to continue? [n]y

Downloading ftp cue-vm-fr_CA-langpack.nme.3.2.1.prt1

Bytes downloaded : 31146425

Validating package signature ... done

ERROR: Invalid package. Please verify if this is a valid package file.

se-172-30-101-11#

Oops, run into a problem?!?!

downloaded the fr_CA package again, and got the same error?


e-172-30-101-11# sh software vers

Cisco Unity Express version (3.2.1)

Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2008 by Cisco Syste

ms, Inc.

Components:

- CUE Voicemail Language Support version 3.2.1.0

se-172-30-101-11# sh soft lice

Installed license files:

- voicemail_lic.sig : 50 MAILBOX LICENSE

- ivr_lic.sig : NULL IVR LICENSE

Core:

- Application mode: CCME

- Total usable system ports: 24

Voicemail/Auto Attendant:

- Max system mailbox capacity time: 18000

- Default # of general delivery mailboxes: 15

- Default # of personal mailboxes: 50

- Max # of configurable mailboxes: 65

Interactive Voice Response:

- Max # of IVR sessions: Not Available

Languages:

- Max installed languages: 5

- Max enabled languages: 5

se-172-30-101-11#

se-172-30-101-11# sh software pack

Installed Packages:

- Installer (Installer application) (3.2.1.0)

- Thirdparty (Service Engine Thirdparty Code) (3.2.1.0)

- Bootloader (Primary) (Service Engine Bootloader) (2.1.14)

- Infrastructure (Service Engine Infrastructure) (3.2.1.0)

- Global (Global manifest) (3.2.1)

- Service Engine license (License for the Service Engine) (2.1.2.0)

- Auto Attendant (Service Engine Telephony Infrastructure) (3.2.1.0)

- Voice Mail (Voicemail application) (3.2.1.0)

- Bootloader (Secondary) (Service Engine Bootloader) (2.1.14.0)

- Core (Service Engine OS Core) (3.2.1.0)

- GPL Infrastructure (Service Engine GPL Infrastructure) (3.2.1.0)

Installed Plug-ins:

- CUE Voicemail Language Support (Languages global pack) (3.2.1.0)

- CUE Voicemail US English (English language pack) (3.2.1.0)

se-172-30-101-11#

cogden Wed, 08/06/2008 - 20:10
User Badges:
  • Bronze, 100 points or more

Figured it out.

The Cisco documentation is incorrect.

It is a major misguided typo when it comes to how to add a language pack.


You don't reference the .prt1 file, you need to do a software install add on relevant langpack file you are trying to install.

You will then be prompted for the Language files you want to install. So ensure you have downloaded these (the .prt1 files) to your FTP server.


conf t

software download server url ftp://172.30.101.24/

exit

software install add cue-vm-langpack.nme.3.2.1.pkg


After selection of the LANGUAGES it does a major reload.


See output example below:

se-172-30-101-11# software install add cue-vm-langpack.nme.3.2.1.pkg



WARNING:: This command will install the necessary software to

WARNING:: complete an add-on install. It is recommended that a backup be done

WARNING:: before installing software.


Would you like to continue? [n]y


Downloading ftp cue-vm-langpack.nme.3.2.1.pkg

Bytes downloaded : 992548


Validating package signature ... done

This is add on installation.

Validating installed manifests .............complete.

Found new Add-On subsystem SID: a2ba4f96-3452-40c3-83ad-c442cb6bf42f Name: CUE Voicemail B

razilian Portuguese Version: 3.2.1.0

Found new Add-On subsystem SID: 24cb0b00-ed1c-4463-bf6f-261b15dfb3e7 Name: CUE Voicemail R

ussian Version: 3.2.1.0

Found new Add-On subsystem SID: 3f968fd0-6598-48e2-be1c-4af6c2e02e02 Name: CUE


etc, etc....


STARTED: SQL_startup.sh

STARTED: dwnldr_startup.sh

STARTED: HTTP_startup.sh

STARTED: probe

STARTED: superthread_startup.sh

STARTED: ${ROOT}/usr/wfavvid/run


Booting: [###########################################################>] 100% waiting 98 ..

.

se-172-30-101-11> sh software packages


Installed Packages:


- Installer (Installer application) (3.2.1.0)

- Thirdparty (Service Engine Thirdparty Code) (3.2.1.0)

- Bootloader (Primary) (Service Engine Bootloader) (2.1.14)

- Infrastructure (Service Engine Infrastructure) (3.2.1.0)

- Global (Global manifest) (3.2.1)

- Service Engine license (License for the Service Engine) (2.1.2.0)

- Auto Attendant (Service Engine Telephony Infrastructure) (3.2.1.0)

- Voice Mail (Voicemail application) (3.2.1.0)

- Bootloader (Secondary) (Service Engine Bootloader) (2.1.14.0)

- Core (Service Engine OS Core) (3.2.1.0)

- GPL Infrastructure (Service Engine GPL Infrastructure) (3.2.1.0)


Installed Plug-ins:


- CUE Voicemail Language Support (Languages global pack) (3.2.1.0)

- CUE Voicemail Canadian French (Canadian French language pack) (3.2.1.0)

- CUE Voicemail US English (English language pack) (3.2.1.0)

- CUE Voicemail European French (French language pack) (3.2.1.0)


SYSTEM ONLINE

se-172-30-101-11>





Actions

This Discussion