Dhcp forwarding from one Lan to another through Vlans

Unanswered Question
Aug 5th, 2008

Hy guys,

I have to implement an IP Telephony to a customer site. My customer has already a Cisco 2821 running dhcp on it and a Catalyst 2950 . Now for telefony I have a Cisco 2851 a 2960G and few 2960.

My problem is how can I keep his old dhcp pool for the data vlan and to add a new dhcp to voice vlan?

And another problem is that I don't have any access on the 2821 old customer router.

Temporarly for testing I have made this config on 2851:

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1 10.10.10.10

ip dhcp excluded-address 192.168.10.1 192.168.10.10

!

ip dhcp pool phone

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

option 150 ip 10.10.10.1

!

ip dhcp pool data

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 193.231.233.1

interface GigabitEthernet0/0

description ** assign static IP address to the interface **

ip address 192.168.40.32 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

no ip mroute-cache

duplex auto

speed auto

!

interface GigabitEthernet0/1.100

description ** Voice VLAN **

encapsulation dot1Q 100

ip address 10.10.10.1 255.255.255.0

service-policy output output-L3-to-L2

!

interface GigabitEthernet0/1.200

description ** Data VLAN **

encapsulation dot1Q 200 native

ip address 192.168.10.1 255.255.255.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.40.1

The customer DHCP is: 192.168.40.1-254 255.255.255.0

Thanks in advance!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
n.nandrekar Tue, 08/05/2008 - 23:06

Probably i didnt get your question correctly, because you seem to have the answer to the question you are asking :). The config you have created seems fine. Is that not working? With that config you should be able to retain the old DHCP for the data vlan and use the new pool for the voice..

Regards,

Niranjan

tdrais Wed, 08/06/2008 - 04:59

I assume you have a reason that you cannot just attach your new switches to the old ones. The router could still used a tagged vlan to get the voice to the router and just not pass the vlan 100 over to the old switch.

The DHCP server is not your issue since that could be fixed with a helper you issue is that you want to leave the gateway network for .40 network on the old router.

The pc must have a layer2 connection to the default gate and if they must pass though the router on the g0/1 port you must make the router look like a switch. This can be done by creating a bridge group and bridging g0/1.200 to g0/0 but I would only do that as a last resort.

You really just want to connect the new switches to the old for the data vlan.

Michael Ciulei Wed, 08/06/2008 - 08:49

Thanks for reply,

Today I have made a test with the above config and I have made a nat to have access to the .40 network and all seems to be alright. Tomorrow I'll move pc's from the old network (non cisco switches) to the new network and see if all's ok.

I will post the results.

Thanks again,

Michael

Actions

This Discussion