LMS 3.1 - Manage devices by hand in RME

Unanswered Question
Aug 6th, 2008


After managing the first four devices in CM I wanted to do the same in RME.

But in RME I don't want to manage all devices, so I have to manage them by hand over the "Add Devices".

The problem is, that I can not choose devices over the selector. It looks like all devices are manage.

Using the option "Enable Auto Mode" -> "Manage All Devices" all four devices will managed immediately!

I have a lot of devices which I don't want to manage in RME, so the auto-mode is no solution.

Thank you for your help!


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
miheg Wed, 08/06/2008 - 05:41

Yes, and for the devices te reappear you must remove them from RME first.

The add devices only show devices not yet in RME.

So in RME -> Admin -> Device Management -> Device Management Settings you have to unselect "Automatically Manage Devices from Credential Repository"

And then remove the devices you don't want to manage



Sven Hruza Wed, 08/06/2008 - 06:05

Hi Michel,

I don't understand...

There is no device in RME and the "Add devices" shows no devices, too!

To use "Auto Manage" and delete devices I don't want to manage is not a alternative.



Joe Clarke Wed, 08/06/2008 - 08:37

You can choose the manage devices by hand (RME > Device Management > RME Devices > Add), or setup an auto manage policy under RME > Admin > Device Management > Device Management Settings.

Say you have 30 routers, and you only want to manage 10 of them, you have two choices. The first is to manage them by hand (this doesn't sounds like what you want). The second is to create a Common Services custom group which matches just the devices you want to manage. Then, turn on auto-management for that group in RME.

Sven Hruza Wed, 08/06/2008 - 23:55

I thought about the choise to auto-manage the devices in RME once more.

I created very particular custom groups, so I am able to do this like you said, Joe.

The problem is, after configuring the auto-manage nothing happens.

Is there something else to do?

RME is running on the second server as a slave.

Is there anything to do?

DCR-Status tells that the server is added and reachable.


Sven Hruza Thu, 08/07/2008 - 01:33

I solved the problem!

The Approver List was the failure.

I did not include the system-admin in the list.

After doing that and restart the server all devices from my selected groups were added in RME!

Thanks for your help!


Sven Hruza Thu, 08/07/2008 - 05:11

Joe, one question...

The first auto-manage worked fine, but how I can force RME to start another run?

I tested Inventory-Job or something else, but no new nodes were managed by RME.

Thanks a lot!


Joe Clarke Thu, 08/07/2008 - 06:34

Auto manage should just work. As new devices are added into DCR, RME's DeviceManagement daemon should get an event, and start processing the new devices.

Sven Hruza Fri, 08/08/2008 - 00:44


RME gets no information about new devices in DCR on my system.

What I have to configure to getting information from DCR?

I thought the Approval Settings, but it does not work.



Joe Clarke Fri, 08/08/2008 - 08:16

Approval settings have nothing to do with this. When you add a new device to the DCR master, then go to RME > Devices > Device Management > RME Devices > Add, does the new device show up there?

Sven Hruza Mon, 08/11/2008 - 01:49

Hi Joe,

no, the devices in RME -> Add are not the same like in DCR.

It is an older version of the devices!

After the discovery I change the "display name" of all new devices from IP to a individual name and I configure the SNMP and telnet settings.

Then I go to RME to put the new devices in it.

But there the devices have not the new name!

There is no update from DCR on server A (master) to RME on server B (slave).

By the way, the update of discovered devices on slave to master works fine!

After restarting both servers the new devices are available in RME and are managed automatically!


Joe Clarke Mon, 08/11/2008 - 09:44

I suggest you open a service request with TAC at this point, so they can walk you through the DCR debugging steps. There are a few steps involved in doing this right.


This Discussion