Voice and Video Qos Configuration

Unanswered Question

Hi All

I am trying to configure my 3750 switch for VoIP, Video Conferencing and Data

I have two scenarios to do this. Scenario A remaps cos-dscp and uses Policy Maps.

Scenarion B uses queues

The flow of traffic for Voice, Video and data is as follows

3750 <-- 1Gi--> 6500 <--100Mb--> 7200 <--WAN T3--> 7200 <-- 100Mb--> 6500 <--1Gi--> 3750

My question is which the preferred method for configuring Qos on the 3750. Scenario A seems to adopt the Keep it simple rule but is it the most effective.

Your feedback on this would be appreciated

SCENARIO A

==========

mls qos map cos-dscp 0 8 16 24 34 46 48 56

mls qos

!

!

!

class-map match-all VOICEVLAN

match access-group name Voice

!

Class-map match-all VIDEOVLAN

match access-group name Video

!

class-map match-any Call-Setup

match ip dscp cs3

match ip dscp af31

!

policy-map Voice-Policy

class VOICEVLAN

set dscp ef

trust dscp

class VIDEOVLAN

set dscp af41

class class-default

fair-queue

!

ip access-list extended Voice

permit ip 10.1.131.0 0.0.0.255 any

!

ip access-list extended Video

permit ip 10.1.132.129 0.0.0.127 any

!

interface GigabitEthernet1/0/46

service-policy input Voice-Policy

!

SCENARIO B

==========

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 1 2 4

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos srr-queue output dscp-map queue 2 threshold 1 16

mls qos srr-queue output dscp-map queue 2 threshold 1 18 20 22

mls qos srr-queue output dscp-map queue 2 threshold 1 25

mls qos srr-queue output dscp-map queue 2 threshold 1 34

mls qos srr-queue output dscp-map queue 2 threshold 1 34 36 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24 26

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 3 10 12 14

mls qos queue-set output 1 threshold 2 70 80 100 100

mls qos queue-set output 1 threshold 4 40 100 100 100

!

interface GigabitEthernet1/0/46

queue-set 1

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion