Night-Service Bell on FXS interface

Unanswered Question
Aug 6th, 2008
User Badges:

I'm looking to enable the night-service bell on an internal FXS interface on a CME router. I have read that there is a way to register an FXS port as an ephone via SCCP. Can anyone provide me with an example of how to do this? I have a VIC2-2FXS located at voice-port 0/2/0 and 0/2/1. Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mchin345 Tue, 08/12/2008 - 14:26
User Badges:
  • Silver, 250 points or more

night-service bell :

To mark an IP phone to receive night-service bell notification when incoming calls are received on ephone-dns that are marked for night service during night-service time periods, use the night-service bell command in ephone or ephone-template configuration mode.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_n1ht.html#wp1017495


Hi


I have previously spent time trying to get night service to work for a customer.


The end result after talking to Cisco, is that it's not supported, however I haven't re-tested the solution in version 4.2 or 4.3 of CME.


I could see the SCCP Ringing messages getting sent to the FXS port, but there was never any output from the FXS port.


I think after seeing how quickly the Ringer on / Ringer off messages where sent, that the FXS never had time to drive the voltage on the output.


The workaround is to use a ATA186 and enable night service on that ephone.


I'm interested to see if any improvements have been made on later versions of CME code, please let us know :)


If you want to try the FXS SCCP config under night service, I could see if I still have the configuration.


Regards,


Mike.


m_poublon Wed, 08/13/2008 - 06:08
User Badges:

I just resorted to using an ATA186 as well. I was working with Cisco TAC and they provided me with a config example for using SCCP on an FXS port. The problem that I ran into was that for this to work, I had to have a fairly specific version of the IOS loaded. Unfortunately, this router is located in Louisiana and I'm in Michigan and there isn't enough free space on the router for both IOS images.


For now, I'm going to use the ata with a DN that people forward thier phones to. This will ring the ata for 60 seconds before going off to an auto attendant. During these 60 seconds, people can get to a phone and use the group pickup function. This solution (if it works well) emulates what the users used to do with an old phone system for night service.


I'll post back if this solution has taken care of the problem. Thanks for your input everyone.


-Mike

wrickk_2 Thu, 10/11/2012 - 17:40
User Badges:

Did you ever resolve this? I am having the exact same issue


Thanks!

Michael Lee Fri, 10/12/2012 - 18:58
User Badges:

Hi


The issue is the standard VIC FXS modules do not provide enough ringing voltage during the night bell mode to trigger the ringing. There are ring extenders avaliable in the US to resolve this problem, they just connect in-line with the output of the FXS port.


Or the other options could be to configure the standard FXS port as a normal anagloue extension in CME, then use the command under the ephone-dn call-forward night-bell (note the command syntax might not be exactly correct but close)


While I haven't tried this personally it should just ring the analogue extension normally.


Regards,


Mike.

NB: old account was leemj001

wrickk_2 Fri, 10/12/2012 - 19:29
User Badges:

Thanks, Mike.


I was able to get it working.



Regards,


Rick

Actions

This Discussion