FXS Port MGCP Configuration for Fax

Unanswered Question
Aug 7th, 2008

Hello,

There are a lot of litterature / Documentation concerning Fax in a Cisco VoIP Environment.

Problem is we can easely get lost regarding all the possible configuration, ie Fax Relay, T38 Fax Relay, Modem Passthrough, Fax Passthrough, combination with H323, MGCP or SIP and finally I could not get a simple example that would make my Fax work :)

Running CUCME 6.1, GW 3825, HWIC-8-FXS-DID card, E1, MGCP. The GW works fine and the FXS analog port also, when using a analog phone. However fax transmission causes some problems. Failure after communication is established. I aim at using Modem passthrough.

current mgcp config:

mgcp

mgcp call-agent 10.126.0.225 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

Thanks for your help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ayodeji oladipo... Thu, 08/07/2008 - 06:47

Hi,

You need to add this command on your MGCP gateway.

mgcp modem passthrough voip codec g711alaw

mgcp fax t38 inhibit...This will diable fax relay as this is enabled by default and will override fax passthrough

After adding this command ensure you issue the command..no mgcp...and then mgcp..to re-initialize mgcp application

Also please ensure that there are no slips on your controller...

use the show controller e1/t1 command to see if there are slips on it.

m.schlienger Thu, 08/07/2008 - 07:27

Thanks for your reply.

Question:

- do I have to set Fax Relay or Fax Passthrough (since I won't use any of them) on MGCP configuration on the CUCME ?

- would no ccm-manager fax protocol command be useful, as it disables Cisco Fax Relay ?

Michael Hanes Thu, 08/07/2008 - 11:53

If you want to use modem passthrough for your fax calls then you should disable Cisco fax relay as well using "no ccm-manager fax protocol cisco" because it is on by default and will take precedence over modem passthrough.

-David

feisalb Mon, 12/09/2013 - 14:16

Hello

Can someone provide me with the config of the cucme as I can't find any document
In how to configure it as mgcp, lots of documentation for sccp but not mgcp.

Thanks

Sent from Cisco Technical Support iPhone App

Actions

This Discussion