changing STP settings of a port

Unanswered Question
Aug 7th, 2008

Using CM's Topology Services we want to modify STP settings on a given interface.

We go through the following menu path:

Network Views --> LAN Edge View

<Select one SwitchCloud>

View --> Display View

<Select one device>

Reports --> Spanning Tree Configuration

<Select one spanning tree instance>

This last step is where we sometimes have trouble. Indeed, for some we get a list of available VLANs and we can modify interface settings (e.g. portfast enable <--> disable) whereas for other the list is empty. We tried other available Spanning Tree Type options (i.e. MST, MISTP) without any success.

It seems to us that this issue is due to the fact that unsuccessful switches run Rapid-PVST which is not one of the Spanning Tree Type options available (only "regular" PVST is featured).

Can someone confirm that suspicion and, if so, is it something supported in LMS 3.0 (we're still on LMS 2.6, Campus Manager 4.0.8)?

Kind regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Joe Clarke Fri, 08/08/2008 - 09:53

This could have to do with the switches in this switch cloud. They must support the CISCO-STP-EXTENSIONS-MIB, and Data Collection must be able to collect STP information from them (meaning you cannot have a '@' in your community string, or you must have properly configured SNMPv3 contexts).

Since you are also running an older version of Campus, you may be seeing a bug where Data Collection does not properly complete. You might also try upgrading to Campus 4.0.11, then reinitializing the ANI database, and performing a fresh Data Collection. Once upgraded, the ANI database can be reinitialized with:

NMSROOT/bin/perl NMSROOT/campus/bin/ -restore


This Discussion