Prompt problem

Unanswered Question
Aug 8th, 2008
User Badges:

Hi,


we have the following problem in our CRS script. The first two steps in script are Accept and Play prompt. The problem is that a part of the prompt (or sometimes the whole prompt) is sometimes missing (this happens 50% of the time, but not always). We tried putting 3 seconds delay at the start of the script and also befor the Play prompt step, but it isnt helping.

Are there any other solutions for this problem?


Regards,


Marko

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chris Deren Fri, 08/08/2008 - 07:17
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Is it happening to external calls or internal or both? If the delay step does not fix it and it is occasional it is probably due to network issues.


Chris

Chad Stachowicz Fri, 08/08/2008 - 13:48
User Badges:
  • Silver, 250 points or more

so I have this same problem right now when a call goes into Queue. The prmpt always plays externally. Never internally on primary. Reports have said it works from internal on the HA though. it didnt work at all until I added a 2 second delay. Also, sometimes when it transferes to the agent they hear MoH for a few secs..



Chad

markotisler Sun, 08/10/2008 - 22:25
User Badges:

I also thought it was a network problem at first, but it seemed odd that it always occured at the beginning of the first prompt, and then worked ok with MoH and other prompts.

I swapped the first prompt with another new prompt and have had no problems so far. Could something with the prompt file itself be causing this problem?


Regards


Marko



markotisler Sun, 08/10/2008 - 23:24
User Badges:

Well, it seems like it didnt help after all - the problem's back with this prompt also. The same happens if there's no prompt at all, just a 10 second delay (caller should be hearing ring-back here) and the whole ring-back is sometimes replaced with silence. No idea what's going on (there was practically no activity on network while i was testing this).


Also, it doesn't matter whether if it is an outside call or a local call.


Regards,


Marko

Patrik Englund Mon, 08/11/2008 - 03:50
User Badges:

Check the prompt itself and if it is coded correctly ie. is using Bit Rate 64kbps, Audio sample size 8 bit, Audio sample rate 8kHz and Audio format CCITT u-Law

markotisler Mon, 08/11/2008 - 04:24
User Badges:

Yes, the prompt is OK. The same thing happens if i use Cisco default prompts that come with the IPCC itself.



Patrik Englund Mon, 08/11/2008 - 04:29
User Badges:

Calling search space on the cti ports?

Calling search space on the trigger?

markotisler Mon, 08/11/2008 - 04:57
User Badges:

If it would be a CSS problem it would either work or not work, i think. But here, it sometimes works, at other times it half-works. :)



Patrik Englund Mon, 08/11/2008 - 05:26
User Badges:

If you have only one ivr it should always work or fail if you only using one trigger.

If you uses 2 ivr's you could have a css issue if you dont have the same settings on the ivr ports. I dont know what you are running so i cannot make comments to that

markotisler Mon, 08/11/2008 - 05:29
User Badges:

I understand, however, all the ports as well as the triggers are in the same CSS.

Chad Stachowicz Tue, 08/12/2008 - 11:59
User Badges:
  • Silver, 250 points or more

Yeah I have this issue right now aswell. Are you on UCCX 5.02_Build 64?

Chad

markotisler Wed, 08/13/2008 - 22:10
User Badges:

UCCX 5.0(1)_Build433 is the version. Could be the same bug though.


Marko

Chad Stachowicz Thu, 08/14/2008 - 10:50
User Badges:
  • Silver, 250 points or more

Well,


Turns out our problem was firewall's. Blocking UDP RTP streams between UCCX servers and the users.



Cheers,


Chad

markotisler Mon, 09/29/2008 - 10:08
User Badges:

Chad,


was the firewall a PIX? How was it blocking the UDP RTP streams exactly? What did you have to fix? We have been unable to fix this for weeks...


Regards,


Marko

markotisler Mon, 04/27/2009 - 00:49
User Badges:

We opened a TAC case for this. The problem is the PIX when its openning connections, so we swapped it for ASA and problem solved.

Patrik Englund Mon, 08/11/2008 - 04:29
User Badges:

Calling search space on the cti ports?

Calling search space on the trigger?

Actions

This Discussion