BRI troubleshooting

Unanswered Question
Aug 8th, 2008

Hi,

Now, BRI troubleshooting.

please technical advices me that look attached file about debug isdn status.

following message is isdn status log.

ISDN status:

#sh controllers bri

BRI unit 0:

layer 1 operating in LT-T mode.

Layer 1 is PENDING ACTIVATION. (ISDN L1 State F4)

D Channel Information:

idb at 0x4647D748, driver data structure at 0x46495F44

Infineon Chip Version 0x1

Infineon Registers:

Int. Status Register [ISTA]=0x00, Aux. Int. [AUXI]=0x00

D-channel: Int. Status Reg: [ISTAD]=0x00, Status. Reg: [STARD]=0x40

Mode Reg: [TR_MODE]=0x01

Transceiver Reg: [TR_CONF0]=0x00

Test mode Reg: [TMD]=0x00

IOM Control Reg: [IOM_CR]=0x08

Status Register [STAR]=0x40, Mode Register [MODED]=0xCA

Serial Data Strobe Control Reg: [SDS1_CR]=0x00, [SDS2_CR]=0x00

RX Buffer Descriptor is at 0x46496310, Buffer size 1524

pak=0x46496954 data_ptr=0x3F850FB4 partial_size=0x0

TX Buffer Descriptor is at 0x464962C4

pak=0x0 data_ptr=0x0 partial_size=0x0

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns 0 d channel collisions

B1 Channel Information:

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns 0 d channel collisions

B2 Channel Information:

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns 0 d channel collisions

#sh isdn status(calling)

Global ISDN Switchtype = ntt

ISDN BRI0/0/0 interface

dsl 0, interface ISDN Switchtype = ntt

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

TEI = 255, Ces = 1, SAPI = 0, State = ESTABLISH_AWAITING_TEI

Layer 3 Status:

0 Active Layer 3 Call(s)

CCB:callid=8004, sapi=0, ces=1, B-chan=1, calltype=VOICE

Active dsl 0 CCBs = 1

The Free Channel Mask: 0x80000002

#sh isdn status(call out)

Global ISDN Switchtype = ntt

ISDN BRI0/0/0 interface

dsl 0, interface ISDN Switchtype = ntt

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Fri, 08/08/2008 - 02:14

Hello Shigenori,

layer 1 operating in LT-T mode.

Layer 1 is PENDING ACTIVATION. (ISDN L1 State F4)

You have problems at ISDN Layer1 check cables, isdn switch type is NTT and should be fine if you are in Japan

Use switch type basic-ntt I'm afraid ntt is for PRI

ESTABLISH_AWAITING_TEI means that layer2 ISDN q.921 is waiting to receive a valid ISDN TEI that is sort of local address.

From debug we see

Aug 6 14:56:29 JST: ISDN BR0/0/0 **ERROR**: handle_l2d_srq_mail: Layer 1 inactive

*Aug 6 14:56:29 JST: ISDN BR0/0/0 EVENT: handle_l2d_srq_mail: Activating Layer 1

*Aug 6 14:56:29 JST: ISDN BR0/0/0 EVENT: isdn_sw_cstate: State = 4, Old State = 0

Use switch type basic-ntt I'm afraid ntt is for PRI

PRI will not require a TEI but BRI expects it to work

see

http://www.cisco.com/en/US/tech/tk801/tk379/technologies_tech_note09186a0080094b76.shtml

Hope to help

Giuseppe

Giuseppe Larosa Fri, 08/08/2008 - 02:20

Hello Shigenori,

ntt is ok, basic-ntt does not exist

sorry for that.

follow the instructions on the link you need to restart the BRI because it is waiting a response from switch

F4

Awaiting Signal

When the TE wishes to initiate activation, it sends an Activation signal to the NT and awaits a response.

Hope to help

Giuseppe

Actions

This Discussion