How to change e-mail subject in Change Audit e-mail notification

Unanswered Question
Aug 9th, 2008

Dear all,

could you advice if it is possible to change somehow Subject field in a Change Audit e-maill notification to get a messages with format "Config changed on <devicename> by <username>" in the Subject area? Can I use any variables for this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Joe Clarke Sat, 08/09/2008 - 08:24

While you can change the subject, you cannot add variables to the subject. You can, however, write a script which takes the ChangeAudit record as its argument. Then, you can construct an email with all of the fields set to what you want.

Helpdesk_ Sun, 08/10/2008 - 21:18

Dear jclarke,

thanks for your prompt response. But may I ask you to send me the script file (SampleEmailScript, correct?) itself? I couldn't find it neither in an installed CW directories nor in CW distribution files. I also surfed Internet to find it but unsuccessfully.

Thanks and regards,


Joe Clarke Sun, 08/10/2008 - 21:19

There are no scripts shipped with LMS by default. This would be one you would have to write.

Helpdesk_ Sun, 08/10/2008 - 23:37

hm-m-m. Bad news. I thought people just took ready for use file and added necessary arguments in a .bat file. It is time to start learning pearl script language.

Joe Clarke Mon, 08/11/2008 - 09:43

The shipped with earlier versions of LMS (e.g. 2.2). I looked at this in conjunction with Change Audit AAs, and it doesn't look like this will help. As it stands now, there isn't enough details passed to the script like there are for syslog AAs. Doing what you want will take an enhancement to the existing Change Audit AA script functionality.

Helpdesk_ Wed, 08/13/2008 - 20:54

Great. Thanks. Do I have a chance to see status/actions corresponded to this case? Or you will post an answer here?



Joe Clarke Wed, 08/13/2008 - 22:03

You should be able to track it in the Bug Toolkit on

Helpdesk_ Fri, 09/12/2008 - 02:45

Dear jclarke, how long it used to takes to get an answer from Cisco? There is still a message that "Bug ID CSCsr93354 is currently under review for publishing on Bug Toolkit and will be available soon, often within one or two business days." Almost one month has passed already.

Joe Clarke Fri, 09/12/2008 - 07:00

It could be that this bug will not be published because it is an enhancement request. In that case, you will have to check the release notes of future LMS releases to see if it has been implemented. Right now, we are winding down the design phase of LMS 3.2, and it's still not clear what the full list of bugs to be fixed will be. It could be that LMS 3.2 will have this implemented, but it may have to wait until LMS 3.3.


This Discussion