Designing Network Infrastructure

Unanswered Question
Aug 10th, 2008
User Badges:

Hi,

I am working on a project to design and implement new data center infrastructure Also migrate users from the old network . The current setup is that network has several vlans and each switch is connected to the main switch via fibre. The new network infrastructure will have two core switches 6509, several 4500 series switches for wiring closet and 3750 switches where the devices will be connected. 4500 switch will be connected to both core switches 6509 via fibre. In this situation, what will be the proper network design? Will appreciate any thoughts.


Thanks



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
Marwan ALshawi Mon, 08/11/2008 - 00:30
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

through ur discription i havnt heard from u any thing about the ditribution layer!!

u need the distribution layer befor the core layer

in other words

it should be like


access switches-- distribution --core

basicaly

on the access layer creat all the required vlans but keep them on lyer two

dont make and vlan interface

on the distribution layer

creat the same vlans here layer two

and then creat a vlan interface SVI fopr each vlan


and this vlan interface will be the default gateway for the access switches in the corsponding vlan


next if u want or and u see it required make a core layer

while i think u dont need it

in ur case the distibution layer will be called

distribution/core layer


the link between the access switches and the dist. switches must be trunk


if u want redundancy and high availabilty


u need two dist switches with identical config to some extend

i mean the ip addresing not meant to be the same but in the same ranges with regard to each vlan


and configure hsrp on the dist switches

in the case the default gateway for each vlan access layer user will be the vertiual interface of that vlan hsrp group

also u have to make the active switch in the hsrp group the root switch in the spanning tree config


for dhcp make the ip helper address on each SVI on the dist. switching pointing to a dhcp server and useing the proper VIP for that vlan group as the default gateway


and add the

spanning-tree portfast on each access port that will be a dhcp client


good luck


please if helpful rate

cowetacoit Mon, 08/11/2008 - 06:36
User Badges:

couldn't you just use the access layer switches as distribution/access switches? I mean, they are 4500 and 3750s so they will have all of the routing features plus the port density.

Marwan ALshawi Mon, 08/11/2008 - 06:53
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

ok,


in this case they will stay considered access switches

but this method will be called ROUTED ACCESS Siwtched network


and the distribution layer will be the same place

but the demorication point i mean the layer two and layer three config and transition will be on the access switches not in the distribution switches


and now the view deffrent

the access switches will have and do the following


Switched vlan interfaces SVIs [cleants default gateway in each corsponding vlan]


routing protocol and ip routing enabled

end point connection to the switch will be layer two with vlan assigned

connection between the access switch and the Dist/core switch [uplink] will be through routed interface [layer three interface with IP address]

comunication between the Dist and access through a routing protocol

it is recomended that u dont use HSRP for redundancy but u use equal routing paths becuase it is much quicker in convergence time


finaly no spanning tree is required any more


so the method u gonna use it very good and more reliable


good luck


please, if helful Rate

mrahman0302 Mon, 08/11/2008 - 13:49
User Badges:

Thanks for your thoughts. So what I got is that:


on access layer switch:

(config)# vlan 6

interface GigabitEthernet1/0/1

switchport access vlan 6


On Distribution Switch:


(config)# interface vlan 6

no ip address


on Core Switch:

(config)# interface vlan 6

ip address 192.168.x.x 255.255.255.0


Did I get that right?


Thanks






Marwan ALshawi Mon, 08/11/2008 - 16:03
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

as u mentioned u gonna use layer three switchs

on the access layer

and i told this will be called routed access layer

so the vlan interface in ur case should be configured on the access switch and the interface between the acces and Dist and Dist and core all routed ports [ layer three port] like a router port

for eaxmple


lets say this is the port connected to the dist switch on the access switch

On Distribution Switch:


interface fa 0/1

no switchport

ip address 1.1.1.1 255.255.255.0


and this is dist side:

interface f 1/1

no switchport

ip address 1.1.1.2 255.255.255.0


and so on


and what i have told u so far is a background

now the following link will give u the deails and all the config and concept with regard to ur case


http://www.cisco.com/application/pdf/en/us/guest/netsol/ns431/c649/ccmigration_09186a00808f6c34.pdf


good luck


please, if helpful Rate


Actions

This Discussion