CCM 4: Phone firmware updation

Answered Question
Aug 11th, 2008
User Badges:

Hi,

I installed CCM 4.2(3) and having phones 7945 and 7965.When i try to configure phone manually, i cann't see these model in the list but if i configure AutoRegistration, phone registered fine and in properties it showed exact Model 7945. For this i also download and install .exe for these models but still can not see in model list. This may be basic question in CCM but i don't know.

Please tell me the solution.

Best Regards

Correct Answer by espereir about 8 years 8 months ago

Hello Rameez,


Another good answer from my friend Rob; as mentioned by Rob, the problem is that you do not have the DevPack installed; You need to install have at least 4.2(3)SR2 with ciscocm.4-2-3-DevPack-30. My advise will be to upgrade CCM to the latest SR and DevPack versions; please download and install the following packs:


- 4.2(3)SR4a: ciscocm.4-2-3-sr4a.exe

- 4.2(3.46): ciscocm.4-2-3-DevPack-46.exe


Install them in the same order as listed above, you will see the 7945 phone option after SR4a has been installed, however, it is highly recommended to upgrade to DevPack 46 since it contains the latest FW versions.


- In order to get SR4a, please browse through the "Software Delivery System" and select the following options: Voice and Unified Communications > Cisco Unified CallManager Version 4.2 > Unified Communications Manager Updates > 4.2(3)SR4a


In order to get DevPack46, please browse through the "Software Delivery System" and select the following options: Voice and Unified Communications > Cisco Unified CallManager Version 4.2 > Unified Communications Manager/CallManager Device Packages > 4.2(3.46)


Hope this helps!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (3 ratings)
Loading.
Chris Deren Mon, 08/11/2008 - 10:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

You need to apply latest phone devicePack that includes these phone types.


Chris

Rob Huffman Mon, 08/11/2008 - 10:17
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Rameez,


No worries .. this gets confusing :) When you don't find the IP Phone model listed in the Device defaults you can either install the required Device Pack (which adds the Firmware as well) or upgrade to a supported later CCM Version. Here is the minimum required device Pack for the 7945,7965 and 7975 and CCM 4.2



Device packs are required to support the in the Cisco Unified Communications Manager database. Table 1 specifies the minimum required device pack version. To access the device packs, go to the following URL:


http://www.cisco.com/public/sw-center/sw-voice.shtml


4.2(3)SR2


ciscocm.4-2-3-DevPack-30


Hope this helps!

Rob

rameezsardar Mon, 08/11/2008 - 23:12
User Badges:

Friend,


Thank you for reply. I upgrade CCM to "ciscocm.4-2-3-sr2b" but still cann't see model type in new ip phone window.


Waiting for next suggestion.


Best Regards

Correct Answer
espereir Mon, 08/11/2008 - 23:58
User Badges:
  • Silver, 250 points or more

Hello Rameez,


Another good answer from my friend Rob; as mentioned by Rob, the problem is that you do not have the DevPack installed; You need to install have at least 4.2(3)SR2 with ciscocm.4-2-3-DevPack-30. My advise will be to upgrade CCM to the latest SR and DevPack versions; please download and install the following packs:


- 4.2(3)SR4a: ciscocm.4-2-3-sr4a.exe

- 4.2(3.46): ciscocm.4-2-3-DevPack-46.exe


Install them in the same order as listed above, you will see the 7945 phone option after SR4a has been installed, however, it is highly recommended to upgrade to DevPack 46 since it contains the latest FW versions.


- In order to get SR4a, please browse through the "Software Delivery System" and select the following options: Voice and Unified Communications > Cisco Unified CallManager Version 4.2 > Unified Communications Manager Updates > 4.2(3)SR4a


In order to get DevPack46, please browse through the "Software Delivery System" and select the following options: Voice and Unified Communications > Cisco Unified CallManager Version 4.2 > Unified Communications Manager/CallManager Device Packages > 4.2(3.46)


Hope this helps!

Actions

This Discussion