MPLS VPN SOO

Answered Question
Aug 11th, 2008
User Badges:
  • Gold, 750 points or more

Hi,


How can i attach SOO to connected subnets without advertising it using network command?


regards

Devang Patel

Correct Answer by dara111983 about 8 years 9 months ago

HI Devang,


You can try using the

#Ip vrf Site-map ____



Interface config level command.


Reply back if it solves!


Thanks,

Dara

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
devang_etcom Mon, 08/11/2008 - 10:40
User Badges:
  • Gold, 750 points or more

above post is related to the BGP configuration not EIGRP.

lee.reade Tue, 08/12/2008 - 06:21
User Badges:
  • Silver, 250 points or more

Hi,


I am not able to test this myself but, if you are redistributing the connected routes into BGP then in the redistribute command, call a route-map and use the "set extcommunity soo"


I dont see why this would not work.


HTH


LR

Correct Answer
dara111983 Tue, 08/12/2008 - 11:25
User Badges:

HI Devang,


You can try using the

#Ip vrf Site-map ____



Interface config level command.


Reply back if it solves!


Thanks,

Dara

lee.reade Wed, 08/13/2008 - 05:17
User Badges:
  • Silver, 250 points or more

Hi,


The interface site-map configuration is specific to EIGRP use and not BGP.


HTH


LR

dara111983 Wed, 08/13/2008 - 05:47
User Badges:

Hi Lr,


You are right, but it would still work.


However I guess the solution contradict with the requirement of adding the network statement.



Thanks,

Dara

devang_etcom Wed, 08/13/2008 - 11:55
User Badges:
  • Gold, 750 points or more

Dara,


thanks for your reply... and yes it worked for me with ip vrf sitemap... and it attached SOO to interface prefix...


Here is my config and show output for the same...

!

router bgp 99

address-family ipv4 vrf ABC

redistribute connected

!

route-map SOO permit 10

set extcommunity soo 99:99


!

interface Loopback99

ip vrf forwarding ABC

ip vrf sitemap SOO

ip address 99.99.99.99 255.255.255.255

end


R99#show ip bgp vpnv4 all 99.99.99.99

BGP routing table entry for 1:11:99.99.99.99/32, version 8

Paths: (1 available, best #1, table ABC)

Advertised to non peer-group peers:

150.1.2.2 150.1.7.7 150.1.8.8

Local

0.0.0.0 from 0.0.0.0 (150.1.9.9)

Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced,

best

Extended Community: SoO:99:99 RT:1:11,

mpls labels in/out 22/aggregate(ABC)


thanks & regards

Devang Patel

Actions

This Discussion