ahmed_saleh Mon, 08/11/2008 - 11:04
User Badges:

Ok thanks but I need to tell you my router have tow interfaces

S1/0 connected to ISP1

S1/1 connected to ISP2

ISP1 support us with 6MB

ISP2 support us with 8MB


I need to aggregate 6MB+8MB = 14 MB



And I have 1 ip in each Serial interface I can't use virtual template interface or Interface Dialer


Did you have anther solution?


Giuseppe Larosa Mon, 08/11/2008 - 11:18
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ahmed,

in this case I would suggest to use load-balancing at layer 3 but Bandwidths are different on the two links.

You should use FR subifs 4 on link 1 and 3 on link 2, then increase the maximum-paths to 7 on your routing protocol (if possible)

Otherwise you should use EIGRP with variance for unequal load-balancing but I don't think you are using it with your providers

I don't think you can aggregate them.

What routing protocol do you use with your two providers ?


Hope to help

Giuseppe

ahmed_saleh Mon, 08/11/2008 - 11:24
User Badges:

Ok I will drown my network now and I will post it for you again

ahmed_saleh Mon, 08/11/2008 - 12:34
User Badges:

Sorry I am running dynamips to share what I will do this is not a rally configuration

________________________________________________________________


Rack1R2(config-subif)#do show run int f 0/0.1

Building configuration...


Current configuration : 194 bytes

!

interface FastEthernet0/0.1

encapsulation dot1Q 10

ip address 192.168.1.2 255.255.255.0

no snmp trap link-status

standby 1 ip 192.168.1.254

standby 1 priority 150

standby 1 preempt


Rack1R4(config-subif)#do show run int e 0/0.1

Building configuration...


Current configuration : 147 bytes

!

interface Ethernet0/0.1

encapsulation dot1Q 10

ip address 192.168.1.4 255.255.255.0

no snmp trap link-status

standby 1 ip 192.168.1.254



1 then I will configure anther 2 vlan like these steps

2 I will configure NAT

3 it's the critical point for me aggregation the link in tow serial interface in eche router


4 if you have complete configuration please post it for me




Attachment: 
Giuseppe Larosa Wed, 08/13/2008 - 06:17
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ahmed,

if you need to use NAT the best strategy is to use two pools one provided by ISP1 and one used by provider2.

At the routing level I would suggest to use the slower link as a backup.


hope to help

Giuseppe


ahmed_saleh Mon, 08/11/2008 - 13:31
User Badges:

please I need response about this configuration just I am use this to share what I will do in the network I am not share a task for study but I will make this configuration in real environment

Giuseppe Larosa Mon, 08/11/2008 - 10:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Ahmed,

the most common option is multilink PPP

you can follow this example:


int ser1/0

no ip address

enc ppp

ppp multilink 1


int ser1/1

no ip address

enc ppp

ppp multilink 1


interface multilink1

enc ppp

ppp multilink 1

ip address x.x.x.1 255.255.255.252


the configuration needs to be replicated on the other side's router using x.x.x.2 as the ip address.


use the following link as a reference


http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/mlppp_over_serial.html


Hope to help

Giuseppe


Actions

This Discussion