IPS upgrade syntax

Unanswered Question
Aug 12th, 2008

Hello -

I am trying to upgrade my IPS 4215 to IPS-K9-6.1-1-E2.pkg file and I can't seem to get the upgrde to start. I have tried the following command from both my PC and the TFPT server.

upgrade ftp://user@

I type in the password when it ask and then I type yes on the warning msg. And then I receive the following error msg.

Error: execUpgradeSoftware : Connect failed.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
marcabal Tue, 08/12/2008 - 08:16

1st issue is that the 4215 is not supported by IPS 6.1.

IPS 6.0 is the last version for support of the 4215.

(New 6.0 Service Packs, Engine Updates, and Signatures are still being created, and these can be used on the 4215).

However, that doesn't explain your download problem. You should have received an error that the 4215 is not supported, and not a "Connect failed" error. So something else must be wrong.

Have you tried FTPing from a different machine to your FTP server to verify that the username and password you entered are correct?

Also check to see what directory you have to "cd" to in order to see the file.

If you have a TFTP-Root directory on your ftp server it is possible that the ftp connection to your server may put you directly in TFPT-Root from the start. In which case you would not need to specify the directory. And your upgrade command could be:


If all else fails use the "packet capture FastEthernet0/0" command in a separate CLI connetion to capture the packets for the ftp upgrade. Then download the file and look at it with a program like WireShark. You can see what the error is that is being returned from your FTP server.

siscisco05 Tue, 08/12/2008 - 09:17

ok, I figured out the problem I needed to switch ports in the command from 21 to 22. I have another question - since version 6.1 is not supported on the IDS 4215, when I click on configuration tab in the new IME it says that I must be on version 6.1 to view but it provides a link to open the old version of the IDS device manager- but that link does not work. How can I get the link to work?


This Discussion